Page 1 of 1

Win32 Disk Imager 1.0 Error 5:

Posted: Sun Jun 10, 2018 10:39 pm
by OldPCGuy
I'm trying to image/clone my SD card to my Win10 PC hard drive for backup.

I get this error;

"An error occurred when attempting to get a handle on the file. Error 5: Access is denied."

I'm running it as admin on a Win10 PC. I've never had issue going the other way using SDFormat and Win32 Disk Image to create an SD card.

Is there a better way to make image/clone copy backups?

Re: Win32 Disk Imager 1.0 Error 5:

Posted: Mon Jun 11, 2018 9:38 am
by DougieLawson
Use the piclone program that's built in to Raspbian. You get a better copy that way that isn't dependent on the size of your SDCard.

Re: Win32 Disk Imager 1.0 Error 5:

Posted: Mon Jun 11, 2018 3:40 pm
by OldPCGuy
I initially looked at using the Pi utility. The way the Pi shows my card reader and devices made me nervous. It appeared to list each partition separate, microSD /boot and a separate device for microSD/system or something like that. It did the same thing for the target card because it is already loaded with the Raspbian Switch OS

Pi/Linux file systems confuse me a bit.

Is there an easy tutorial for the Pi clone utility?

Re: Win32 Disk Imager 1.0 Error 5:

Posted: Mon Jun 11, 2018 3:42 pm
by DougieLawson
The piclone utility takes the current active system and copies it to an SDCard in a USB reader. No instructions or tutorial needed. Just fire it up and forget it until cooked.

Re: Win32 Disk Imager 1.0 Error 5:

Posted: Tue Jun 12, 2018 1:18 am
by OldPCGuy
Ah! struggling. Tried a card already loaded with Stretch hoping it would simple overwrite; nope. Formatted with SDFormat, now I get can't create file system.

edit: Got it!

with SDFormat I skipped Quick erase went to Full (Erase) that didn't work. I had to format FULL (Overwrite) and the SD cloned fine after that.

I just wish SD copier (piclone) had a pre-format overwrite option built-in.

Old dog learning new tricks! :mrgreen:

Re: Win32 Disk Imager 1.0 Error 5:

Posted: Tue Jun 12, 2018 5:10 am
by rpdom
The SD copier shouldn't need the new card to be pre-formatted as it reformats the card when it runs.

Having said that, I wonder if there is a bug that prevents it formatting if the card is already formatted in a certain way? I have no way to test this at the moment.

Re: Win32 Disk Imager 1.0 Error 5 + Windows 10 1709 [SOLVED: switch off Defender]

Posted: Thu Jun 21, 2018 8:45 am
by Rinco van der Baan
Windows 10 Pro
Version 1709
OS Build 16299.492
Win32 Disk Imager - 1.0

I got the "Error 5 access denied error" when trying to write an image to
the (empty) SD-card.
I tried almost every solution I could find with Google but the error stayed.
I even tried "etcher", which also gave a similar error.

In the past this always worked without problem. So I suspected, that some
Windows 10 update caused the problem.

Finally (after 4 hours of stress) I tried the unlikely possiblity of
disabling the (standard Windows) virusscanner:

- Windows Defender Security Centre
- Virus & threat protection setting
- Real-time protection: switch to Off

After this writing the image worked without a problem!

Re: Win32 Disk Imager 1.0 Error 5:

Posted: Mon Sep 24, 2018 7:54 am
by hela
Similar situation here - after switching off the real time protection off Avast / Avira it works.