williamvz
Posts: 7
Joined: Fri May 04, 2018 3:36 pm

PI 3B+ not booting. Act led not blinking

Fri May 04, 2018 3:57 pm

Dear all,

I feel foolish to start with a help question straight away but I'm lost after searching forums for multiple days. I bought a Pi 3B+ some weeks ago and wanted to get it up and running in my network the other day, without much of succes.

I have it seen working when I first plugged it in (some weeks ago, but had no time to play around with it at that time). That is: I've seen both leds blinking, and saw it pop up in the connections on my router and switch. The 3B+ comes with Noobs pre-installed.

When I turned it on this morning, the only thing that happend was the red power led blinking continuously. Here's what I tried in the meantime:
  • I've always booted it with the power adapter that came along with it (wall adapter)
  • I've booted it while connected to my switch, and to my router, as well as without any ethernet connected
  • I've booted it while connected to different HDMI screens, as well as without any hardware connected
  • I've tried several different SD cards, both the one that came with it, as well as ones that have been working flawlessly for years already
  • I've formatted those cards using the official SD Card Formatter software as well as Windows built in formatting options
  • I've flashed the images to the cards using Etcher, as recommended.
  • I've flashed both the full and lite versions of both Noobs and Raspbian onto the cards in different cases
And none of it has done the trick for me. Whenever I put power on the Pi, the only thing that happens is the red led that turns on (which is good if you ask me). I have not seen the Act led blink a single time. The router and switch are working correctly since other connected devices (NAS, Ikea hub, ...) are accessible.

Anybody has any thoughts?

drgeoff
Posts: 9926
Joined: Wed Jan 25, 2012 6:39 pm

Re: PI 3B+ not booting. Act led not blinking

Fri May 04, 2018 6:59 pm

The red LED blinking means that your power supply or cable is inadequate or that the software on the SD card is too old for a 3B+. Are you using a 18 April 2018 version?

Router. ethernet etc is not necessary to see it boot when connected to a HDMi display.

You should always do a software shutdown before removing power. Failure to do so risks corrupting files, including OS ones, on the card.

The "not booting" stick contains all known help..

williamvz
Posts: 7
Joined: Fri May 04, 2018 3:36 pm

Re: PI 3B+ not booting. Act led not blinking

Sat May 05, 2018 9:50 am

Hi,

Sorry, the red LED is not blinking. It is continuously on, which to me sounds like it has enough power.

Concerning software, I have only downloaded the most recent versions of Noobs and Raspbian (both full and lite versions) from the official downloads page. I have not been able to do software shutdowns but since I have formatted the cards subsequently and wrote the images to them again, I would suppose corrupted files would be replaced by working ones.

I have spent multiple hours in the “not booting” sticky and have followed many of the potential options but none have worked so far.

User avatar
B.Goode
Posts: 8987
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: PI 3B+ not booting. Act led not blinking

Sat May 05, 2018 12:11 pm

The 'not-booting' post has the distilled experience of forum users from the last 6 years - it is very unlikely that you have a 'new' problem.

Is it possible that your RPi could have suffered physical or static damage between its first successful demonstration run and your more recent attempts to restart it?

Some observations on what you have reported:
I've tried several different SD cards, both the one that came with it, as well as ones that have been working flawlessly for years already
I've formatted those cards using the official SD Card Formatter software as well as Windows built in formatting options
I've flashed the images to the cards using Etcher, as recommended.
I've flashed both the full and lite versions of both Noobs and Raspbian onto the cards in different cases
Have the older microSD cards previously been used in an RPi, or for some other purpose?

If a microSD card is in a state where it requires reformatting the simple Windows Explorer menu option is not adequate.

A card that is to be created with the Etcher utility does not need to be pre-formatted. (Although the operation is redundant it is not harmful.)

The NOOBS Installer creation process simply requires copying files and folders using standard Windows tools: it cannot be 'flashed' using Etcher.



One common factor in the above is that the card reader-writer used to create the bootable microSD card must be SDHC compatible. It seems that some built-in slots in laptops etc are only SD compatible, meaning they can only handle lower capacity cards up to 2GB. But it seems they fail 'silently' if used for larger cards. An external usb 'dongle' might be a workable alternative.

williamvz
Posts: 7
Joined: Fri May 04, 2018 3:36 pm

Re: PI 3B+ not booting. Act led not blinking

Sat May 05, 2018 8:38 pm

I immediately believe that I'm not bringing in a new problem. However, I am kinda stuck right now.
B.Goode wrote:
Sat May 05, 2018 12:11 pm
Is it possible that your RPi could have suffered physical or static damage between its first successful demonstration run and your more recent attempts to restart it?
It has not been moved outside of the fuse box. there are other devices there and some have been stacked. Could that have caused too much static interference?
B.Goode wrote:
Sat May 05, 2018 12:11 pm
Have the older microSD cards previously been used in an RPi, or for some other purpose?
The SD card that came with the Pi has not been used anywhere else. The other one is a samsung card that has worked flawlessly in my action cam to date.
B.Goode wrote:
Sat May 05, 2018 12:11 pm
If a microSD card is in a state where it requires reformatting the simple Windows Explorer menu option is not adequate.
If I reformatted the microSD card, I always used the official tool from the SD card organization.
B.Goode wrote:
Sat May 05, 2018 12:11 pm
The NOOBS Installer creation process simply requires copying files and folders using standard Windows tools: it cannot be 'flashed' using Etcher.
I know. You copy the files to the source of the microSD card, like I have done here: https://www.dropbox.com/s/9o1kn1p2gc4ll5f/RPI1.png?dl=0
B.Goode wrote:
Sat May 05, 2018 12:11 pm
One common factor in the above is that the card reader-writer used to create the bootable microSD card must be SDHC compatible. It seems that some built-in slots in laptops etc are only SD compatible, meaning they can only handle lower capacity cards up to 2GB. But it seems they fail 'silently' if used for larger cards. An external usb 'dongle' might be a workable alternative.
I am using a Microsoft Surface Book which's built in card reader does support SDHC. I have loaded Noobs again via a dongle, without any difference unfortunately.

User avatar
B.Goode
Posts: 8987
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: PI 3B+ not booting. Act led not blinking

Sat May 05, 2018 9:03 pm

Where are you putting the microSD card prior to powering on the RPi?

The card reader slot is on the otherwise 'empty' side of the board, under the Display connector, near the metal blob embossed with a Raspberry.

The metal contacts on the card need to be directly facing the RPi circuit board itself.

The absence of a green activity light, and nothing appearing on the HDMI display suggests that either the card is not being read, or the content is wrong. Your screenshot of a NOOBS Installer card appears to be correct. Do you see any change to the content of the card after you have tried to boot from it. (You should find that the fat partition has been shrunk to about 2GB and the disk should be renamed Recovery. I would not be surprised to find these changes have not been made.)

No corresponding changes will be detected to a directly imaged (flashed) Raspbian card.

drgeoff
Posts: 9926
Joined: Wed Jan 25, 2012 6:39 pm

Re: PI 3B+ not booting. Act led not blinking

Sat May 05, 2018 11:18 pm

williamvz wrote:
Sat May 05, 2018 8:38 pm
It has not been moved outside of the fuse box. there are other devices there and some have been stacked. Could that have caused too much static interference?
1. If your meaning of "fuse box" is the same as mine, I think that is no place for a RPi.

2. Is the RPi naked or is it by itself inside a non-conducting box? Allowing anything metallic to touch the underside of the board or the GPIO pins has a high risk of killing a RPi.

williamvz
Posts: 7
Joined: Fri May 04, 2018 3:36 pm

Re: PI 3B+ not booting. Act led not blinking

Sun May 06, 2018 7:51 pm

The Pi has been covered in a case while powered on. This version comes with a case by default. My fuse box is a full closet in which all electricity cables come together. That's where my modem is and where all the ethernet lines arrive.

Furthermore, this is how the SD card slot looks like without the cover. Seems right? https://www.dropbox.com/s/rreodskbouv9k ... 3.jpg?dl=0

I happened to recover my iMac from the boxes today (have been relocating recently) so will try if that makes any difference when formatting SD cards or flashing them.

williamvz
Posts: 7
Joined: Fri May 04, 2018 3:36 pm

Re: PI 3B+ not booting. Act led not blinking

Sun May 06, 2018 9:27 pm

B.Goode wrote:
Sat May 05, 2018 9:03 pm
Do you see any change to the content of the card after you have tried to boot from it. (You should find that the fat partition has been shrunk to about 2GB and the disk should be renamed Recovery. I would not be surprised to find these changes have not been made.)
Nothing happens, which makes sense since the activity led is not blinking, therefore suggesting that the Pi is not doing anything following power on.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12413
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: PI 3B+ not booting. Act led not blinking

Sun May 06, 2018 10:37 pm

put this sd-card aside, and buy another (8GB) one, and image it with a fresh copy of raspbian, using the Etcher imaging software.
Try if it boots with this new card, with nothing else attached (except the HDMI cable).

If that doesn't work then you are sure that the PI is unable to read the boot sector from the card, and you can give up. (and throw the PI in a bin). :(

User avatar
hansotten
Posts: 324
Joined: Fri Jul 13, 2012 6:01 am
Contact: Website

Re: PI 3B+ not booting. Act led not blinking

Mon May 07, 2018 6:45 am

mahjongg wrote:
Sun May 06, 2018 10:37 pm
(and throw the PI in a bin). :(
The OP told us he bought the Pi several weeks ago, so he is entitled to a refund/exchange from his supplier if the Pi is really defective.
http://duinorasp.hansotten.com for Raspberry Pi and Arduino and ESP8266
http://retro.hansotten.nl for retrocomputing with the 6502 cpu

drgeoff
Posts: 9926
Joined: Wed Jan 25, 2012 6:39 pm

Re: PI 3B+ not booting. Act led not blinking

Mon May 07, 2018 10:19 am

hansotten wrote:
Mon May 07, 2018 6:45 am
mahjongg wrote:
Sun May 06, 2018 10:37 pm
(and throw the PI in a bin). :(
The OP told us he bought the Pi several weeks ago, so he is entitled to a refund/exchange from his supplier if the Pi is really defective.
The OP also told us that he saw the RPi working. So if it is now defective there is a real possibility that he damaged it.

williamvz
Posts: 7
Joined: Fri May 04, 2018 3:36 pm

Re: PI 3B+ not booting. Act led not blinking

Mon May 07, 2018 7:10 pm

I will indeed do one more check with different SD cards but if that doesn’t work, I’m afraid I will see if I can return it.

williamvz
Posts: 7
Joined: Fri May 04, 2018 3:36 pm

Re: PI 3B+ not booting. Act led not blinking

Wed May 09, 2018 12:50 pm

Same SD card, different Pi...

It worked.

jassenharris
Posts: 1
Joined: Wed Jun 20, 2018 11:45 am

Re: PI 3B+ not booting. Act led not blinking

Wed Jun 20, 2018 11:47 am

Hi,

Same problem with OP, used the SD card to another Pi 3 B+ and it worked. The Pi 3B+ did not boot up even from the start.

hunagyp
Posts: 1
Joined: Sat Aug 04, 2012 7:06 pm

Re: PI 3B+ not booting. Act led not blinking

Fri Jun 22, 2018 8:02 pm

Hi All,
and I joined the club unfortunately...
The very same situation is here too.
I'm curious how up-to-date is this article: http://ozzmaker.com/testing-points-raspberry-pi/
Because based on my measurements, at PP10 testpoint I can measure only 1.8V - which is "brownout" state.
But PP7-8-9 are all OK, 4.95V, 3.27V and 1.75V.
Does anybody have any idea about further debugging?

User avatar
B.Goode
Posts: 8987
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: PI 3B+ not booting. Act led not blinking

Sat Jun 23, 2018 1:48 pm

There is a Troubleshooting guide in Issue 60 of the MagPi magazine which you can access for free online. https://www.raspberrypi.org/magpi/issues/60/

The Raspberry Pi Foundation have a Troubleshooting Guide on their website: https://www.raspberrypi.org/learning/tr ... ing-guide/

These forums have a post which contains all the information currently available about getting an RPi to boot: "STICKY: Is your Pi not booting? (The Boot Problems Sticky)" at viewtopic.php?f=28&t=58151

nbJosh
Posts: 4
Joined: Tue Oct 09, 2018 1:15 pm

Re: PI 3B+ not booting. Act led not blinking

Tue Oct 09, 2018 4:15 pm

I have the same issue,

after about a month of duty as an octopi server for a 3d printer, the pi 3B+ stopped responding, now all it does is light the red LED.

The green no longer flashes.

I am sure that this is not a SD card issue, as the SD card I was running went straight into an older 3b, and booted straight away, and other SD cards from working Pi installations placed into my 3B+ do not boot either.

at the time that this happened, I did not have much time to troubleshoot, and the test/troubleshooting posts were completely lacking on any info regarding the 3B+

I would love to have my 3B+ back up and running for some more projects, Any suggestions?

User avatar
davidcoton
Posts: 4259
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: PI 3B+ not booting. Act led not blinking

Tue Oct 09, 2018 10:43 pm

Do you have a multimeter or oscilloscope? If so, measure the voltage on pin 1 of the GPIO connector. It should be 3V3. Be very careful not to short pin1 to anything else, if you do, the Pi will be dead afterwards even if it wasn't before.
Signature retired

nbJosh
Posts: 4
Joined: Tue Oct 09, 2018 1:15 pm

Re: PI 3B+ not booting. Act led not blinking

Wed Oct 10, 2018 2:26 pm

I get 5v on pin 2, but 0v on pin 1

gkaiseril
Posts: 661
Joined: Mon Aug 08, 2016 9:27 pm
Location: Chicago, IL

Re: PI 3B+ not booting. Act led not blinking

Wed Oct 10, 2018 2:59 pm

It is possible that you have tripped or blown the poly fuse that protects the Pi. Leave it alone with the power off for 24+ hours. Then try to boot it with a fresh SD card with Raspbian. If it boot the ply fuse has reset, if it does not boot the poly fuse is blown and there is no easy fix.

One needs to be careful not to short out the GPIO pins and bottom of the Pi's circuit board by keeping it in a case or mounted above a plastic sheet.
f u cn rd ths, u cn gt a gd jb n cmptr prgrmmng.

nbJosh
Posts: 4
Joined: Tue Oct 09, 2018 1:15 pm

Re: PI 3B+ not booting. Act led not blinking

Wed Oct 10, 2018 4:44 pm

Then it is likely blown, as it has been over a month in a anti-static bag with no power

Josh

User avatar
Burngate
Posts: 6100
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK Tralfamadore
Contact: Website

Re: PI 3B+ not booting. Act led not blinking

Thu Oct 11, 2018 7:59 am

gkaiseril wrote:
Wed Oct 10, 2018 2:59 pm
It is possible that you have tripped or blown the poly fuse that protects the Pi.
If the poly-fuse had tripped, there wouldn't be 5v at pin 2; nor would the pwr LED light.

5v at pin 2 and 0v at pin 1 = blown pmic

PhilE
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2490
Joined: Mon Sep 29, 2014 1:07 pm
Location: Cambridge

Re: PI 3B+ not booting. Act led not blinking

Thu Oct 11, 2018 9:35 am

@Burngate - as I understand it, a very small number of units have been affected by this problem, and we are trying to both diagnose and quantify the issue. I suggest you return the unit to the retailer, who will replace it for you.

User avatar
Burngate
Posts: 6100
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK Tralfamadore
Contact: Website

Re: PI 3B+ not booting. Act led not blinking

Thu Oct 11, 2018 5:25 pm

Sure - as I understand it, "a very small number" have turned up their toes without provocation, and possibly a larger number have had their toes curled by maltreatment. I have no information regarding the numbers, or the number working perfectly well (other than it's greater than one - mine)

I'm not sure I'm fully happy that mine's fine - I'd have liked to experience the problem first-hand. Just as I'd have liked to have a malfunctioning PoE, just to investigate the problem myself.
On the other hand, maybe I should just shut up and let you get on with it.

My only point was that his polyfuse wasn't tripped.

Return to “Troubleshooting”