TheCoder3156
Posts: 6
Joined: Thu Apr 26, 2018 11:39 pm

libsdl1.2-dev won't install

Sat Apr 28, 2018 8:54 pm

I need help installing libsdl1.2-dev. When I try to install with apt-get I get the following error message


pi@raspberrypi:~ $ sudo apt-get install libsdl1.2-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsdl1.2-dev : Depends: libsdl1.2debian (= 1.2.15+dfsg1-4) but 1.2.15+dfsg1-6rpi is to be installed
E: Unable to correct problems, you have held broken packages.

I have done a apt-get update and no luck. Is the package broken or something?

Thanks

User avatar
KLL
Posts: 1453
Joined: Wed Jan 09, 2013 3:05 pm
Location: thailand
Contact: Website

Re: libsdl1.2-dev won't install

Sun Apr 29, 2018 6:11 am

just for info: here i see it is installed??
dpkg -l libsdl1.2debian
ii libsdl1.2debian:armhf 1.2.15+dfsg1-4 armhf Simple DirectMedia Layer

fruitoftheloom
Posts: 23384
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: libsdl1.2-dev won't install

Sun Apr 29, 2018 7:20 am

TheCoder3156 wrote:
Sat Apr 28, 2018 8:54 pm
I need help installing libsdl1.2-dev. When I try to install with apt-get I get the following error message


pi@raspberrypi:~ $ sudo apt-get install libsdl1.2-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libsdl1.2-dev : Depends: libsdl1.2debian (= 1.2.15+dfsg1-4) but 1.2.15+dfsg1-6rpi is to be installed
E: Unable to correct problems, you have held broken packages.

I have done a apt-get update and no luck. Is the package broken or something?

Thanks

What Raspbian release are you running ??
Rather than negativity think outside the box !
RPi 4B 4GB (SSD Boot)..
Asus ChromeBox 3 Celeron is my other computer...

TheCoder3156
Posts: 6
Joined: Thu Apr 26, 2018 11:39 pm

Re: libsdl1.2-dev won't install

Sun Apr 29, 2018 1:38 pm

It should be stretch. How can I find out to be sure?

TheCoder3156
Posts: 6
Joined: Thu Apr 26, 2018 11:39 pm

Re: libsdl1.2-dev won't install

Sun Apr 29, 2018 1:55 pm

Never mind it is stretch. I did the stupid thing by purging libsdl1.2debian already on the system then installed the dev version. I also had to reinstall things it removed to like Minecraft pi and vlc

Return to “Troubleshooting”