ostell
Posts: 1
Joined: Thu Apr 26, 2018 6:39 pm

Error on boot '/init: line 27: can't create /sys/class/leds/led0/trigger'

Thu Apr 26, 2018 6:47 pm

Sorry If i ask the same question twice and for my bad English, but it seems I can't fix the problem yet and I'm stuck. I have a web server running on my Pi. One day i found that my server is down and i try to access my Pi using VNC and i can't. I pluged hdmi, keyboard and mouse and it was on black screen, I reset the pi. When it try to boot i get the color test screen and after a few seconds this messages apear on the screen:

Code: Select all

/init: line 27: can't create /sys/class/leds/led0/trigger: nonexistent directory [ 1.629060] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = w10: May 27 2016 00:13.30 version 7.45.41.26 (r640327) FWID 01-df77e4a7 [ 1.656696] brcmfmac: brcmf_cfg0021_reg_notifier: not a ISO3166 code
After that recovery screen pops up. And it says to hold Shift. I searched in config.txt but there was no "device_tree=" as it was sugested in one other forum. I try to add it to the config.txt, and boot it that way but there was no difference. I also try to change cmdline.txt to boot from partition 2 insted of 7. root=/dev/mmcblk0p2 insted of root=/dev/mmcblk0p2 but there was no result. And now i think what to do. I really need to make my pi to work. I had a web site running on it and all my files and configurations will be gone... Is there any way i can fix that problem or recover my system. I don't want to lose all my information, settings and files.

Thank you in advance!

Return to “Troubleshooting”

Who is online

Users browsing this forum: drgeoff, jonny789 and 13 guests