davidecibel
Posts: 5
Joined: Wed Apr 25, 2018 8:17 am

Motion web access works perfectly in local, but not at all remotely.

Wed Apr 25, 2018 10:04 am

I've used an USB logitech C920 Webcam with a RPi 3 Model B to set up a security camera with Motion, using Raspbian latest version (with the help of google since I've never used linux before, I think one of the guides I've used is this https://tutorials-raspberrypi.com/raspb ... eam-setup/).

Now, if I connect to the control page or to the live stream from my desktop PC on my local network, everything works perfectly, I've even tried to bump up the resolution to 1280x720 and it works like a charm.

So I've forwarded 3 ports on my router (22 for SSH, 8080 for the control page and 8081 for the stream), and tried to connect remotely.

SSH works perfectly. However, if I load the control page, I can only see the text of the page, and not the preview of the stream. The stream on port 8081 does not work at all (from chrome I get an ERR_CONNECTION_TIMED_OUT, I've tried with VLC and get an error as well).

I'm sure it's not an issue related to connection speed since I've got an Emby server on my desktop pc and I can stream HD videos seamlessy (gigabit FTTH).

Could you guys help me figure out what could be the problem? I suspect some firewall settings of my router (unfortunately it's provided by Vodafone, it's a Vodafone Station Revolution) maybe restrict the video stream? but then why does Emby work perfectly?

Return to “Troubleshooting”

Who is online

Users browsing this forum: Harrkev and 8 guests