monkeybike123
Posts: 4
Joined: Thu Dec 28, 2017 6:39 pm

Cannot connect headless raspberry pi 3 to realvnc

Mon Apr 23, 2018 5:43 am

I have followed the instructions on the raspberry pi documentation for real vnc here https://www.raspberrypi.org/documentati ... /README.md and can connect when the pi is plugged into a monitor.

When connecting wirelessly I enter the address given when vncserver is entered into the terminal. When my pi is not connected to the monitor i enter this address at the realvnc viewer (running on windows 10), but get the response "timed out waiting for a response from the computer"

User avatar
KLL
Posts: 1453
Joined: Wed Jan 09, 2013 3:05 pm
Location: thailand
Contact: Website

Re: Cannot connect headless raspberry pi 3 to realvnc

Mon Apr 23, 2018 6:04 am

pls correct the not working LINK

for the remote connection via real VNC it does not matter if there is a monitor connected or not
( many of us use headless only )
for the screen resolution there might be a effect ( also depending on the boot options).

basics: VNC must be enabled via sudo raspi-config

timeout:
yes, the VNC sometimes connects late,
when i check HDMI operation sudo reboot with RASPBIAN Desktop on RPI3B
reboot time 40sec?
when i check via VNC 1m30sec?

klricks
Posts: 6545
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Cannot connect headless raspberry pi 3 to realvnc

Tue Apr 24, 2018 4:34 am

monkeybike123 wrote:
Mon Apr 23, 2018 5:43 am
I have followed the instructions on the raspberry pi documentation for real vnc here https://www.raspberrypi.org/documentati ... /README.md and can connect when the pi is plugged into a monitor.

When connecting wirelessly I enter the address given when vncserver is entered into the terminal. When my pi is not connected to the monitor i enter this address at the realvnc viewer (running on windows 10), but get the response "timed out waiting for a response from the computer"
You cannot copy and paste the compressed link from another forum post. You have to go to the actual web site and copy the URL from the web browser address bar.

What OS are you running? Raspbian Desktop or lite? If running desktop version then don't run vncserver from the terminal. You only need to enable VNC in sudo raspi-config or in the interfaces menu of the GUI config tool then reboot.
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

Return to “Troubleshooting”