haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

No global IPv6

Wed Apr 18, 2018 6:19 pm

Hello,

I just got a new ISP that only supports IPv6 and DSLite. Therefore I have to reconfigure my raspberry that works as an server for VPN, seafile etc. Before I changed my ISP, everything worked perfectly with IPv4 and Dyndns. I have googled a lot and tried to set up a global IP for my Pi But nothing helped so far. I use raspbian jessie. My pi is connected via ethernet to my router, fritzbox 6490.

Here is my output for ifconfig:
eth0 Link encap:Ethernet HWaddr 02:05:07:80:a1:2c
inet addr:192.168.178.21 Bcast:192.168.178.255 Mask:255.255.255.0
inet6 addr: fe80::5:7ff:fe80:a12c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:207 errors:0 dropped:0 overruns:0 frame:0
TX packets:220 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:26460 (25.8 KiB) TX bytes:43204 (42.1 KiB)
Interrupt:117 Base address:0xc000


/etc/dhcpcd.conf Output:
# Inform the DHCP server of our hostname for DDNS.
hostname
# Persist interface configuration when dhcpcd exits.
persistent
# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit
# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# A ServerID is required by RFC2131.
require dhcp_server_identifier
# Generate Stable Private IPv6 Addresses instead of hardware based ones
#slaac private
# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
nohook lookup-hostname

interface eth0
static ip_address=192.168.178.21
static routers=192.168.178.1
static domain_name_servers=192.168.178.1 8.8.8.8

/etc/network/interfaces output:

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet static
pre-up /etc/firewall-openvpn-rules.sh
address 192.168.178.21
netmask 255.255.255.0
network 192.168.178.0
broadcast 192.168.178.255
gateway 192.168.178.1

# IPv6
iface eth0 inet6 static
pre-up modprobe ipv6
address fe80::1
netmask 64

allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

I also tried to connect with my laptop to my Pi in my LAN using the local IPv6. But it also does not work. I typed in my browser http://[fe80::5:7ff:fe80:a12c] but i get a connection timeout. With my IPv4 it works (website with nginx server).

Thanks for help :-)

User avatar
DougieLawson
Posts: 38449
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: No global IPv6

Wed Apr 18, 2018 8:58 pm

Have you enabled DHCPv6 on your Fritz!box?
Do you have a globally unique IPv6 unicast prefix (in the 2000::/3 subnet)?

https://en.avm.de/service/fritzbox/frit ... FRITZ-Box/
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Thu Apr 19, 2018 2:58 pm

Hello DougieLawson,
Have you enabled DHCPv6 on your Fritz!box?
Please see my attached settings of my fritz.box. They are according to the fritz.box manual.
Do you have a globally unique IPv6 unicast prefix (in the 2000::/3 subnet)?
How can I check this?
Attachments
Bildschirmfoto 2018-04-19 um 16.54.16.png
Bildschirmfoto 2018-04-19 um 16.54.16.png (56.96 KiB) Viewed 3626 times
Bildschirmfoto 2018-04-19 um 16.54.06.png
Bildschirmfoto 2018-04-19 um 16.54.06.png (73.25 KiB) Viewed 3626 times

User avatar
DougieLawson
Posts: 38449
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: No global IPv6

Thu Apr 19, 2018 5:26 pm

an FD00::/8 ULA isn't the same as a globally unique 2000:/3 address. The FD00:: block is only available within your LAN. You still need DHCPv6 (or radvd) running so that each LAN station can see the addresses for every other station.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Thu Apr 19, 2018 6:22 pm

Ok. I have heard radvd before. How do I need to configure it?

/etc/radvd.conf ?

User avatar
DougieLawson
Posts: 38449
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: No global IPv6

Thu Apr 19, 2018 6:32 pm

You're probably going to have to ask on your ISP's forum. My TP-LINK router/VDSL2 modem does the IPv6 stuff for free (simple switch) - all I had to do was disable the HE tunnel on my Raspberry.

I ran radvd on that HE tunnel with a very minimal config with just my global unicast /64 prefix defined in there.

Code: Select all

interface eth0
{
        AdvSendAdvert on;
        AdvLinkMTU 1280;
        AdvOtherConfigFlag on;
        prefix 2001:pppp:pppp:pppp::1/64
        {
                AdvOnLink on;
                AdvRouterAddr on;
        };
        route ::/0
        {
        };
};
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Thu Apr 19, 2018 6:41 pm

Hmm ok. Unfortunately I could not find any information at the ISP forum. Can I share any more information that would help for radvd config?

User avatar
DougieLawson
Posts: 38449
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: No global IPv6

Thu Apr 19, 2018 8:27 pm

My problem is the complete lack of documentation for your Fritz!box. Even the German stuff lacks enough detail.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Fri Apr 20, 2018 6:08 pm

Ok understood.
But why is not possible to connect in LAN to my pi via IPv6 address?
also tried to connect with my laptop to my Pi in my LAN using the local IPv6. But it also does not work. I typed in my browser http://[fe80::5:7ff:fe80:a12c] but i get a connection timeout. With my IPv4 it works (website with nginx server).

User avatar
manawyrm
Posts: 34
Joined: Mon Apr 15, 2013 6:18 am
Location: Alfeld (Leine), Germany
Contact: Website Twitter YouTube

Re: No global IPv6

Fri Apr 20, 2018 6:17 pm

Lot of stuff going on here, I'll try to explain as best as I can.

First off:

Code: Select all

iface eth0 inet6 static
pre-up modprobe ipv6
address fe80::1
netmask 64
This disables all the autoconfiguration mechanisms for the interface. You don't want that.
Set "iface eth0 inet6 auto".

http://[fe80::5:7ff:fe80:a12c] can't work. fe80::-addresses are what is called link-local addresses.
These only work when specified with an interface name e.g. fe80::1%eth0. The same address could exist on multiple interfaces.
Browsers don't support link-local addresses, so you can't connect to your nginx, even when suppling the interface name.

Your Fritz!Box configuration is correct. Please don't change anything there.
Your Raspberry Pi needs to do a thing called SLAAC to get an IPv6 address.

The line "pre-up /etc/firewall-openvpn-rules.sh" in your config leads me to believe that you might have turned ip_forwarding on. Is that correct?
If yes: The kernel disables SLAAC in this case.
You might want to look here for further info: https://blog.dhampir.no/content/using-i ... lt-gateway

Best wishes,
Tobias

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Fri Apr 20, 2018 8:28 pm

Thank you very much for your explanations :-)
ip_forwarding
How can I check if it is on or off?

I have changed my interfaces settings:
Set "iface eth0 inet6 auto".
and I added "accept_ra 2"

In addition I disabled pre-up /etc/firewall-openvpn-rules.sh

When i type in "ip -6 route"
I get following error:
unreachable fe80::/64 dev lo proto kernel metric 256 error -101
fe80::/64 dev eth0 proto kernel metric 256

and still no global ipv6 :-(

User avatar
manawyrm
Posts: 34
Joined: Mon Apr 15, 2013 6:18 am
Location: Alfeld (Leine), Germany
Contact: Website Twitter YouTube

Re: No global IPv6

Fri Apr 20, 2018 8:31 pm

Code: Select all

sysctl net.ipv6.conf.all.forwarding
will print 0 if it's disabled.

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Sat Apr 21, 2018 7:23 am

It was set to 1. I disabled it.

But still no global IPv6.

User avatar
manawyrm
Posts: 34
Joined: Mon Apr 15, 2013 6:18 am
Location: Alfeld (Leine), Germany
Contact: Website Twitter YouTube

Re: No global IPv6

Sat Apr 21, 2018 7:26 am

You set it to 0? Have you rebooted since?

EDIT: These settings need to be in /etc/sysctl.conf to be permanent. That's also the place where you need to enable the accept_ra.

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Sat Apr 21, 2018 7:32 am

Yes, sure.
I also added "accept_ra 2". If I check

Code: Select all

sysctl net.ipv6.conf.all.forwarding
it returns 0

Do you not think it has something to do with
When i type in "ip -6 route"
I get following error:
unreachable fe80::/64 dev lo proto kernel metric 256 error -101
fe80::/64 dev eth0 proto kernel metric 256

User avatar
manawyrm
Posts: 34
Joined: Mon Apr 15, 2013 6:18 am
Location: Alfeld (Leine), Germany
Contact: Website Twitter YouTube

Re: No global IPv6

Sat Apr 21, 2018 7:37 am

It's a bit strange.
Could you post your:

/etc/network/interfaces
/etc/sysctl.conf
output of the command "ip6tables -L"
output of the command "ip a"
here? (in a code tag)

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Sat Apr 21, 2018 7:45 am

/etc/network/interfaces

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet static
#        pre-up /etc/firewall-openvpn-rules.sh
    address 192.168.178.21
    netmask 255.255.255.0
    network 192.168.178.0
    broadcast 192.168.178.255
    gateway 192.168.178.1
    pre-up echo 2 > /proc/sys/net/ipv6/conf/eth0/accept_ra
# IPv6
iface eth0 inet6 auto
        accept_ra 2

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
/etc/sysctl.conf

Code: Select all

# /etc/sysctl.conf - Configuration file for setting system variables
# See /etc/sysctl.d/ for additional system variables.
# See sysctl.conf (5) for information.
#

#kernel.domainname = example.com

# Uncomment the following to stop low-level messages on console
#kernel.printk = 3 4 1 3

##############################################################3
# Functions previously found in netbase
#

# Uncomment the next two lines to enable Spoof protection (reverse-path filter)
# Turn on Source Address Verification in all interfaces to
# prevent some spoofing attacks
#net.ipv4.conf.default.rp_filter=1
#net.ipv4.conf.all.rp_filter=1

# Uncomment the next line to enable TCP/IP SYN cookies
# See http://lwn.net/Articles/277146/
# Note: This may impact IPv6 TCP sessions too
#net.ipv4.tcp_syncookies=1

# Uncomment the next line to enable packet forwarding for IPv4
net.ipv4.ip_forward=1

# Uncomment the next line to enable packet forwarding for IPv6
#  Enabling this option disables Stateless Address Autoconfiguration
#  based on Router Advertisements for this host
#net.ipv6.conf.all.forwarding=1
accept_ra 2
output of the command "ip6tables -L"

Code: Select all

Chain INPUT (policy DROP)
target     prot opt source               destination         
ACCEPT     all      anywhere             anywhere             ctstate RELATED,ESTABLISHED
ACCEPT     all      anywhere             anywhere            
DROP       all      anywhere             anywhere             ctstate INVALID
ACCEPT     ipv6-icmp    anywhere             anywhere             ipv6-icmp echo-request ctstate NEW
UDP        udp      anywhere             anywhere             ctstate NEW
TCP        tcp      anywhere             anywhere             tcp flags:FIN,SYN,RST,ACK/SYN ctstate NEW
REJECT     udp      anywhere             anywhere             reject-with icmp6-adm-prohibited
REJECT     tcp      anywhere             anywhere             reject-with icmp6-port-unreachable
REJECT     all      anywhere             anywhere             reject-with icmp6-adm-prohibited

Chain FORWARD (policy DROP)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Chain TCP (1 references)
target     prot opt source               destination         
ACCEPT     tcp      anywhere             anywhere             tcp dpt:1193
ACCEPT     udp      anywhere             anywhere             udp dpt:openvpn
ACCEPT     tcp      anywhere             anywhere             tcp dpt:8001
ACCEPT     tcp      anywhere             anywhere             tcp dpt:8082
ACCEPT     tcp      anywhere             anywhere             tcp dpt:http
ACCEPT     tcp      anywhere             anywhere             tcp dpt:https
ACCEPT     tcp      anywhere             anywhere             tcp dpt:netbios-dgm
ACCEPT     tcp      anywhere             anywhere             tcp dpt:netbios-ssn
ACCEPT     tcp      anywhere             anywhere             tcp dpt:microsoft-ds

Chain UDP (1 references)
target     prot opt source               destination         
ACCEPT     udp      anywhere             anywhere             udp dpt:netbios-ns
output of the command "ip a"

Code: Select all

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: bond0: <NO-CARRIER,BROADCAST,MULTICAST,MASTER,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 02:05:07:80:a1:2c brd ff:ff:ff:ff:ff:ff
    inet 192.168.178.21/24 brd 192.168.178.255 scope global eth0
    inet6 fe80::5:7ff:fe80:a12c/64 scope link 
       valid_lft forever preferred_lft forever
4: tunl0: <NOARP> mtu 1480 qdisc noop state DOWN group default 
    link/ipip 0.0.0.0 brd 0.0.0.0
5: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
    link/none 
    inet 10.8.0.1 peer 10.8.0.2/32 scope global tun0

User avatar
manawyrm
Posts: 34
Joined: Mon Apr 15, 2013 6:18 am
Location: Alfeld (Leine), Germany
Contact: Website Twitter YouTube

Re: No global IPv6

Sat Apr 21, 2018 8:15 am

Ah! Yes, there's the problem.
You have IPv6-firewall rules configured. They are probably blocking the autoconfiguration.

I suppose you have installed a VPN server on the Pi a while back? Do you remember where it's scripts are? Especially something that calls the ip6tables?

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Sat Apr 21, 2018 8:30 am

Yes, I use following script:

Code: Select all

# delete all existing rules
iptables -F
iptables -X
ip6tables -F
ip6tables -X

# basic rules
iptables -N TCP
iptables -N UDP
ip6tables -N TCP
ip6tables -N UDP
iptables -P FORWARD DROP
iptables -P OUTPUT ACCEPT
iptables -P INPUT DROP
ip6tables -P FORWARD DROP
ip6tables -P OUTPUT ACCEPT
ip6tables -P INPUT DROP

# keep existing connections
iptables -A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT
ip6tables -A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -j ACCEPT

# allow loopback traffic
iptables -A INPUT -i lo -j ACCEPT
ip6tables -A INPUT -i lo -j ACCEPT

# drop all traffic with "INVALID" state
iptables -A INPUT -m conntrack --ctstate INVALID -j DROP
ip6tables -A INPUT -m conntrack --ctstate INVALID -j DROP

# allow new incomming ping requests
iptables -A INPUT -p icmp --icmp-type 8 -m conntrack --ctstate NEW -j ACCEPT
ip6tables -A INPUT -p icmpv6 --icmpv6-type 128 -m conntrack --ctstate NEW -j ACCEPT

# open ports for http, https, ssh
#ssh
iptables -A TCP -p tcp --dport 1993 -j ACCEPT
#vpn
iptables -A UDP -p udp --dport 1194 -j ACCEPT
#seafile
iptables -A TCP -p tcp --dport 8001 -j ACCEPT
iptables -A TCP -p tcp --dport 8082 -j ACCEPT
#Samba
iptables -A UDP -p udp --dport 137 -j ACCEPT
iptables -A TCP -p tcp --dport 138 -j ACCEPT
iptables -A TCP -p tcp --dport 139 -j ACCEPT
iptables -A TCP -p tcp --dport 445 -j ACCEPT
#
iptables -A TCP -p tcp --dport 80 -j ACCEPT
iptables -A TCP -p tcp --dport 443 -j ACCEPT

#
ip6tables -A TCP -p tcp --dport 1193 -j ACCEPT
ip6tables -A TCP -p udp --dport 1194 -j ACCEPT
ip6tables -A TCP -p tcp --dport 8001 -j ACCEPT
ip6tables -A TCP -p tcp --dport 8082 -j ACCEPT
ip6tables -A TCP -p tcp --dport 80 -j ACCEPT
ip6tables -A TCP -p tcp --dport 443 -j ACCEPT
ip6tables -A UDP -p udp --dport 137 -j ACCEPT
ip6tables -A TCP -p tcp --dport 138 -j ACCEPT
ip6tables -A TCP -p tcp --dport 139 -j ACCEPT
ip6tables -A TCP -p tcp --dport 445 -j ACCEPT

# handle all new incomming connections for tcp and udp
iptables -A INPUT -p udp -m conntrack --ctstate NEW -j UDP
iptables -A INPUT -p tcp --syn -m conntrack --ctstate NEW -j TCP
ip6tables -A INPUT -p udp -m conntrack --ctstate NEW -j UDP
ip6tables -A INPUT -p tcp --syn -m conntrack --ctstate NEW -j TCP

# reject tcp and udp connections if the port is not open
iptables -A INPUT -p udp -j REJECT --reject-with icmp-port-unreachable
iptables -A INPUT -p tcp -j REJECT --reject-with tcp-rst
ip6tables -A INPUT -p udp -j REJECT --reject-with icmp6-adm-prohibited
ip6tables -A INPUT -p tcp -j REJECT

# reject all other connections
iptables -A INPUT -j REJECT --reject-with icmp-proto-unreachable
ip6tables -A INPUT -j REJECT --reject-with icmp6-adm-prohibited

# save the firewall rules
iptables-save > /etc/iptables/iptables.rules
ip6tables-save > /etc/iptables/ip6tables.rules

echo -------------------------
echo Job Finished
#read -n1 -r -p "Press any key to continue..." key

User avatar
manawyrm
Posts: 34
Joined: Mon Apr 15, 2013 6:18 am
Location: Alfeld (Leine), Germany
Contact: Website Twitter YouTube

Re: No global IPv6

Sat Apr 21, 2018 8:36 am

Ah!
Make a copy of that script, remove all the ip6tables lines and reboot the Pi.
If it then works, we‘ll go from there ;)

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Sat Apr 21, 2018 8:51 am

I removed all ip6 lines.

The problem is that I something messed up with iptables.

I executed the new script without IPv6

Code: Select all

sudo sh /usr/local/bin/iptables.sh

But when I want to enable

Code: Select all

sudo systemctl enable iptables ip6tables
Failed to execute operation: No such file or directory

Code: Select all

systemctl status iptables ip6tables
● iptables.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

● ip6tables.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

Code: Select all

sudo systemctl start iptables ip6tables
Failed to start iptables.service: Unit iptables.service failed to load: No such file or directory.
Failed to start ip6tables.service: Unit ip6tables.service failed to load: No such file or directory.

User avatar
manawyrm
Posts: 34
Joined: Mon Apr 15, 2013 6:18 am
Location: Alfeld (Leine), Germany
Contact: Website Twitter YouTube

Re: No global IPv6

Sat Apr 21, 2018 8:57 am

iptables and ip6tables are not services, you don't need to start them via systemctl.

If your script ran and configured the ip6tables properly it should work.
Have you rebooted in between?

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Sat Apr 21, 2018 9:01 am

I did it according to this manual
https://blog.doenselmann.com/firewall-f ... banana-pi/

Yes I restarted but still does not work. I get following output for
ip6tables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

User avatar
manawyrm
Posts: 34
Joined: Mon Apr 15, 2013 6:18 am
Location: Alfeld (Leine), Germany
Contact: Website Twitter YouTube

Re: No global IPv6

Sat Apr 21, 2018 9:06 am

OK. I don't see a reason why your Pi needs a firewall configuration at all, but that's another story.

Code: Select all

net.ipv6.conf.all.forwarding=0
net.ipv6.conf.all.accept_ra=2
net.ipv6.conf.all.eth0.accept_ra=2
net.ipv6.conf.all.default.accept_ra=2
Try putting this in your /etc/sysctl.conf. Reboot after that.

haunty
Posts: 17
Joined: Wed Apr 18, 2018 6:01 pm

Re: No global IPv6

Sat Apr 21, 2018 9:59 am

It finally works :-) I have got an ipv6 global address :-) Thank you very much manawyrm for your help to clean up my code :-) You are a genius ;-)
In

Code: Select all

/etc/dhcpcd.conf
I changed "slaac private" to "slaac hwaddr" and now it works.

I think it was a combination of iptables and slaac config. SSH and nginx webserver already checked and they work with my global ipv6 address. Only seafile with https is left.

Return to “Troubleshooting”