jonaslorander
Posts: 19
Joined: Wed Oct 29, 2014 6:14 am
Contact: Website

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Fri Jun 29, 2018 8:15 pm

Hi, did anyone find a solution for this? I just got my first RPi3b+ and I got the exact same problem as MineSweGamer. I'm alos located in Sweden.

Changing the wifi conutry works for a few minutes, and never survives a reboot. setting the REGCONTRY to SE in /etc/default/crda doesn't work either.

MineSweGamer
Posts: 18
Joined: Thu Mar 22, 2018 9:28 pm

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Sat Jun 30, 2018 12:42 pm

jonaslorander wrote:
Fri Jun 29, 2018 8:15 pm
Hi, did anyone find a solution for this? I just got my first RPi3b+ and I got the exact same problem as MineSweGamer. I'm alos located in Sweden.

Changing the wifi conutry works for a few minutes, and never survives a reboot. setting the REGCONTRY to SE in /etc/default/crda doesn't work either.
I did find a Hotfix for it.
Just type in the terminal

Code: Select all

sudo iw reg set SE
After that you can access the WiFi menu like normal so its just one extra step. The SE in the command stand for Sweden. Don't know of any permanent fix though. problably up to the RaspberryPi Team to figure out.
My Pi: Raspberry Pi 3 Model B+, Samsung Pro Plus MicroSDXC 64GB, KKSB Stainless Metal Case.

jonaslorander
Posts: 19
Joined: Wed Oct 29, 2014 6:14 am
Contact: Website

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Sat Jun 30, 2018 1:34 pm

Thanks, it works fine. Even though it isn''t persistent through reboots it easy enough to use when you have to change network (which probably won't be very often).

Meowser
Posts: 1
Joined: Sun Jul 22, 2018 9:23 am

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Sun Jul 22, 2018 9:27 am

Have you tried starting with a freshly written sd card of raspbian?
Does your router operate with a hidden ssid?

jonaslorander
Posts: 19
Joined: Wed Oct 29, 2014 6:14 am
Contact: Website

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Sun Jul 22, 2018 7:31 pm

I tried both fresh and not fresh. My router does not use hidden SSID. AAnd there are like 25 other wlans around me and non is seen. I it is only the ethernet widget in the gui that has this problem. In the clip it works fine to scan for networks. And if I add the network to wpa_supplicants the pi will connect to it.

missRaspberry
Posts: 1
Joined: Fri Aug 10, 2018 4:59 pm

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Fri Aug 10, 2018 5:09 pm

I have the same issue in the Netherlands, country code NL. I got a raspberry pi 3 B+ startup kit with everything already installed.
when I change the country to Netherlands (via UI Preferences or raspi-config), it temporarily works, until a reboot.

My wpa_supplicant.conf file looks like this (before and after reboot, looks the same):

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=NL

network={
ssid="XXXX"
psk="XXXXX"
}

edit: version of the (updated) pi is:
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian

How can I put in a script to set the country at startup? Because I guess that is the only workaround so far.

olio
Posts: 33
Joined: Tue Feb 02, 2016 8:55 am

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Thu Jan 03, 2019 3:43 pm

H,
I have a similar issue as soon as I modify the "wpa_supplicant.conf" file which comes with a fresh raspbian Stretch on a new SD card in a new Pi 3B+ with adding a specific network,
e.g.
crtl_interface=DIR=/var/run/wpa_supplicant GROUP= netdev
update=1
country=LU

network {
ssid = "eduroam"
identity = "my_user_name"
psk = "my_password"
#+ other specific network settings like eap, key_mgmt, ...
}
after a reboot, I can't see anymore wifi networks in the GUI but the message "wifi country not set". As soon as I uncomment the network specific lines in the wpa_supplicant.conf and have only the original lines that are created with the first set-up of the Pi, then I can see that the wifi interface is active again and I see all available networks in the GUI. Unfortunately eduroam is locked in this configuration (greyed out, not clickable)...that's why I wanted to modify the wpa_supplcant.

Is there any other way to connect to a wifi network with a comand line as wpa_supplicant.conf doesn't seem to work for me?

Greetings and have a nice evening!
Oliver

Schorschi
Posts: 220
Joined: Thu Nov 22, 2012 9:38 pm

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Tue Feb 12, 2019 4:34 am

Has anyone found a fix for this? This is driving me nuts. Pretty much makes using wifi on my new Pi useless. Is the Pi design team not aware of this issue?

Ernst
Posts: 1246
Joined: Sat Feb 04, 2017 9:39 am
Location: Germany

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Tue Feb 12, 2019 7:07 am

Schorschi wrote:
Tue Feb 12, 2019 4:34 am
Has anyone found a fix for this? This is driving me nuts. Pretty much makes using wifi on my new Pi useless. Is the Pi design team not aware of this issue?
The Pi design team is aware that many users make mistakes, for this reason the box is red to improve visibility.

Please be specific, what is the model of your Pi, what OS and version, what is the contents of /etc/wpa_supplicant/wpa_supplicant.conf. Please post the information using Code tags.
The road to insanity is paved with static ip addresses

cxkoda
Posts: 1
Joined: Wed Feb 13, 2019 8:33 pm

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Wed Feb 13, 2019 8:46 pm

i have exactly the same problem - but in austria.
my configuration of wpa_supplicant.conf worked just fine in the beginning. it was set up in the same way as other users posted before. then, after rebooting i got the "no wifi country set" error.

DirkS
Posts: 9968
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Wed Feb 13, 2019 9:49 pm

cxkoda wrote:
Wed Feb 13, 2019 8:46 pm
i have exactly the same problem - but in austria.
my configuration of wpa_supplicant.conf worked just fine in the beginning. it was set up in the same way as other users posted before. then, after rebooting i got the "no wifi country set" error.
So what's in your /etc/wpa_supplicant/wpa_supplicant.conf after the reboot?
Is your SD card read only?

wumessiah
Posts: 1
Joined: Wed Feb 20, 2019 3:22 am

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Wed Feb 20, 2019 3:25 am

So I tried several of the suggestions on here and ultimately decided it must have been a corruption in my installation. I rebooted the Pi and held down shift to get to the boot loader menu and just reinstalled it. Oddly even during the boot loader option it was able to see my networks which over the WiFi which is strange. In either case, upon re-installation everything is working fine and no problems so far (knock on wood).

lazyanalyst
Posts: 1
Joined: Sat May 25, 2019 5:51 pm

Re: Can't connect to wifi but wifi country has been set properly (Pi 3 Model B+)

Sat May 25, 2019 5:53 pm

I found this thread, because I was having the issues mentioned above (country not being set, wifi not getting a dhcp lease on boot).

I found the instructions here to help: https://weworkweplay.com/play/automatic ... i-network/

Specifically, filling out the rest of the `network` {} blob and editing the interfaces config within /etc/network/interfaces.

Return to “Troubleshooting”