pleriche
Posts: 90
Joined: Mon Oct 14, 2013 8:44 am

Raspbian Stetch Lite - VNC gives tiny window

Wed Apr 04, 2018 9:30 am

I downloaded the latest Raspian Stretch Lite 2018-03-13 for my PiZero 1.2 (no camera connector or WiFi), used a console connection to enable ssh, then in raspi-config, I enabled boot into GUI and VNC.

Connecting with VNC I got a mini 200x300 pixel window only.

I've had that before, and knew that all you have to do is change the resolution in raspi-config, which I did - but this time with no effect!

I tried disabling and re-enabling one or two of the original steps with no effect.

I slept on it (usually works a treat) and this morning I searched for all files with vnc in their filename hoping to find the relevant config file, but drew a blank. There's no /home/pi/.vnc which I might have expected, and the /root/.vnc contains nothing relating to screen resolution. If I could just find my mini/standard HDMI adapter I'd have tried a real screen.

Maybe I should have done things in a different order, but in any case there would seem to be a missing screen resolution line in a config file somewhere which should have been inserted automatically.

Regards - Philip

mattmiller
Posts: 2214
Joined: Thu Feb 05, 2015 11:25 pm

Re: Raspbian Stetch Lite - VNC gives tiny window

Wed Apr 04, 2018 9:35 am

I always just edit /boot/config.txt and un-comment the framebuffer_width and height lines and adjust the values to suit

pleriche
Posts: 90
Joined: Mon Oct 14, 2013 8:44 am

Re: Raspbian Stetch Lite - VNC gives tiny window

Wed Apr 04, 2018 10:25 am

Hmmm... that didn't work either. Just reflashing my SDCard with Raspbian Stretch Hevi (non-Lite) which I imagine has vnc pre-installed.

pleriche
Posts: 90
Joined: Mon Oct 14, 2013 8:44 am

Re: Raspbian Stetch Lite - VNC gives tiny window

Wed Apr 04, 2018 10:55 am

To confirm, works fine with Stretch Hevi. Initially vnc gave me a window which seemed to be 660x420 (no idea where it got that resolution from), and changing it in raspi-config from the default of 720x480 to 1024x768 worked.

Will probably stick with Hevi. I went for light thinking that was an old 4GB card, but in fact it's 16GB.

Return to “Troubleshooting”