UF_DoC
Posts: 49
Joined: Wed Jul 01, 2015 9:00 am

Ethernet Died after Upgrade??? [solved]

Sat Mar 31, 2018 5:25 pm

Hi,

I did a sudo apt-get update and sudo apt-get upgrade and now my raspberry pi 3 does not connect via Ethernet to my router. :cry:

I have my ethernet managed by network manager before. now when I do a do a manual connection it say:

Code: Select all

[email protected]:~ $ sudo nmcli device connect eth0
Error: Failed to add/activate new connection: Connection 'eth0' is not available on the device eth0 at this time.

Code: Select all

[email protected]:/ $ nmcli device show 
GENERAL.DEVICE:                         eth0
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         B8:27:EB:BE:83:61
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
WIRED-PROPERTIES.CARRIER:               off

GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536
GENERAL.STATE:                          10 (unmanaged)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.ADDRESS[1]:                         127.0.0.1/8
IP4.GATEWAY:                            --
IP6.ADDRESS[1]:                         ::1/128
IP6.GATEWAY:                            --

GENERAL.DEVICE:                         wlan0
GENERAL.TYPE:                           wifi
GENERAL.HWADDR:                         B8:27:EB:EB:D6:34
GENERAL.MTU:                            1500
GENERAL.STATE:                          10 (unmanaged)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.ADDRESS[1]:                         172.24.1.1/24
IP4.GATEWAY:                            --
IP6.ADDRESS[1]:                         fe80::ba27:ebff:feeb:d634/64
IP6.GATEWAY:                            --

[email protected]:/ $ nmcli device status 
DEVICE  TYPE      STATE        CONNECTION 
eth0    ethernet  unavailable  --         
lo      loopback  unmanaged    --         
wlan0   wifi      unmanaged    --  
The following packages were updated.

Code: Select all

[email protected]:~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  raspberrypi-sys-mods
The following packages will be upgraded:
  base-files bind9-host bluez-firmware bsdutils cpp-6 cron curl dbus ffmpeg firmware-atheros firmware-brcm80211 firmware-libertas firmware-misc-nonfree firmware-realtek g++-6 gcc-6 gcc-6-base
  isc-dhcp-client isc-dhcp-common libapache2-mod-php7.0 libapparmor1 libasan3 libatomic1 libavcodec57 libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libbind9-140 libblkid1 libc-bin
  libc-dev-bin libc-l10n libc6 libc6-dbg libc6-dev libcc1-0 libcurl3 libcurl3-gnutls libcurl4-openssl-dev libdbus-1-3 libdbus-1-dev libdns-export162 libdns162 libfdisk1 libgcc-6-dev libgcc1 libgomp1
  libicu57 libisc-export160 libisc160 libisccc140 libisccfg140 liblwres141 libmosquitto1 libmount1 libncurses5 libncursesw5 libncursesw5-dev libpam-systemd libpostproc54 libraspberrypi-bin
  libraspberrypi-dev libraspberrypi-doc libraspberrypi0 libsmartcols1 libssl1.0.2 libssl1.1 libstdc++-6-dev libstdc++6 libswresample2 libswscale4 libsystemd0 libtasn1-6 libtinfo-dev libtinfo5 libubsan0
  libudev-dev libudev1 libuuid1 libvorbis0a libvorbisenc2 libvorbisfile3 libvpx4 libwavpack1 libwbclient0 libxml2 locales mosquitto-clients mount multiarch-support ncurses-base ncurses-bin ncurses-term
  openssh-client openssh-server openssh-sftp-server openssl php7.0 php7.0-cli php7.0-common php7.0-json php7.0-opcache php7.0-readline pi-bluetooth raspberrypi-bootloader raspberrypi-kernel raspi-config
  samba-common ssh systemd systemd-sysv tzdata udev util-linux uuid-dev
117 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
and after the upgrade uname shows:

Code: Select all

 Linux piRadioTest 4.14.30-v7+ #1102 SMP Mon Mar 26 16:45:49 BST 2018 armv7l GNU/Linux 
Could someone please assist.
Thanks

UF_DoC
Posts: 49
Joined: Wed Jul 01, 2015 9:00 am

Re: Ethernet Died after Upgrade???

Wed Apr 11, 2018 9:16 pm

Hi Pi Experts.

Just bumping this up in the hope that someone can point me in the right direction or at least what to check?

I reproduced this by flashing to a previous image I took as backup and doing an upgrade again.

Regards,

UF_DoC
Posts: 49
Joined: Wed Jul 01, 2015 9:00 am

Re: Ethernet Died after Upgrade???

Fri Apr 13, 2018 7:59 am

Issue is resolved by recompiling and installing NetwrokManager. I still don't quite understand why this would have fixed the issue, maybe a library used by NM was using changed as part of the recent updates?

In any case maybe this will help someone in the future.

Cheers,

Return to “Troubleshooting”