toto8551
Posts: 2
Joined: Sun Mar 18, 2018 7:52 pm

Pi3B+ : USB+ethernet file transfer problem

Sun Mar 18, 2018 8:29 pm

Hi,

I have problems while transferring files from an USB external HDD or USB flash drive connected on the new RPi 3B+ to another computer via SFTP or samba. After a random amount of data transfered, the transfer rate drop to 0 and stay like that for at least 30 min ( I canceled the transfer after that time).

I cannot see any error on the standard raspbian system logs. I am running raspbian stretch with the last updates, I also did a firmware upgrade with rpi-update.

The RPi 3B+ is powered with an official raspberry power supply (2.5A) and I tried with a spare one.
I tried to give more power with an external power supply for the USB HDD without any change, but like I got the same problem with an USB flash drive, I don't expect a power issue or ?

I tried to transfer files with thunar, pcmanfm, scp or rsync. rsync is the only one working, but with a strong fluctuation of the transfer rate (from 0 to 20Mo/s). scp tell me that the file is "stalled" and stop any progress.

If I start the same SD card with a RPi 3B (not plus) the file transfer is working like a charm ( I used it for almost 3 years like that).

I followed tips from this link without success.

I having no problems during ssh sessions or with vnc.

Any ideas ?

edit : thanks Jamesh : I submitted an issue on the Linux github projet : issue 2449
Last edited by toto8551 on Sun Mar 18, 2018 8:45 pm, edited 1 time in total.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 20459
Joined: Sat Jul 30, 2011 7:41 pm

Re: Pi3B+ : USB+ethernet file transfer problem

Sun Mar 18, 2018 8:34 pm

Thanks for the report. It is probably worth creating an issue on our Linux github repository, that way it won't be missed by the correct engineers, who don't necessarily inhabit the forums.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Please direct all questions to the forum, I do not do support via PM.

pcmanbob
Posts: 4338
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Pi3B+ : USB+ethernet file transfer problem

Sun Mar 18, 2018 10:05 pm

Thought I would attempt to test this myself just to see if I could recreate the problem.

Pi 3B+ running raspbian stretch with desktop up to date as of 16th march.
connected to a wired gigabyte network, powered by an official raspberry pi 2.5A PSU

USB3.0 flash drive 16G silicon power containing 11.6 GB of mixed data form small text files up to raspbian image file of over 2GB.

PC 4 core 4.2GHz with 4GB of ram running windows XP which I use for all my pi related things connected to the same gigabyte wired network
running winSCP.

I successfully copied the entire USB flash drive form the pi to the PC in 13 mins 2 seconds, with winSCP reporting transfer speed between 629KB/s to 20.4MB/s depending on the size and type of file being transferred.

Did this twice with different amounts of data to be transferred without any problems.

Don't know if this is of any help but I guess more data is always better when trying to solve problems.
Last edited by pcmanbob on Tue Mar 20, 2018 4:11 pm, edited 1 time in total.
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

toto8551
Posts: 2
Joined: Sun Mar 18, 2018 7:52 pm

Re: Pi3B+ : USB+ethernet file transfer problem

Mon Mar 19, 2018 9:51 pm

I did another test.

Now I am back with the official kernel of the raspbian stretch : 4.9.80-v7, and it is working up to now.
I transfered 10Go from an USB HDD with a rate of 20 Mo/s.

pgallagher69
Posts: 1
Joined: Tue Mar 20, 2018 10:14 pm

Re: Pi3B+ : USB+ethernet file transfer problem

Tue Mar 20, 2018 10:17 pm

I'm having the same issue on 4.14.27-v7+ on a Pi 3B+.

Can't copy large files... I've tried pretty much everything I can online.

I tried downgrading my firmware to 4.9.8 v7+, but when I reboot, I just get the Rainbow screen and four flashes of the green LED.

I then took the card out, put it in a RPi 2 and it boots just fine... So I then needed to re-update the firmware to 4.14.27-v7+ and plug the card back into my Pi 3B+ to get it to boot... Frustrating!

I'm on wifi now while I wait for a fix :-D

Return to “Troubleshooting”

Who is online

Users browsing this forum: Bing [Bot] and 52 guests