Page 2 of 2

Re: problems with stretch static ip dhcpcd

Posted: Mon Jul 23, 2018 7:51 am
by rpdom
Ernst wrote:
Mon Jul 23, 2018 7:13 am
Do you know what device is being used ? :)
That is entirely irrelevant. The Pi will auto-crossover on 2 or 4 pairs as needed.
I have used it Pi to Pi, Pi to Laptop and Pi to desktop. Never had any issues on 100BaseT or 1000BaseT.

Re: problems with stretch static ip dhcpcd

Posted: Mon Jul 23, 2018 8:33 am
by Ernst
rpdom wrote:
Mon Jul 23, 2018 7:51 am
Ernst wrote:
Mon Jul 23, 2018 7:13 am
Do you know what device is being used ? :)
That is entirely irrelevant. The Pi will auto-crossover on 2 or 4 pairs as needed.
I have used it Pi to Pi, Pi to Laptop and Pi to desktop. Never had any issues on 100BaseT or 1000BaseT.
I believe you, but there are too many unknowns in this equation. The "device" is not identified, the characteristics of the switch are unknown, the cabling type is unknown. I have see enough failures where everybody said that it can't be the equipment, from bad taps on yellow cable to stretched fiber cable because it was 5 cm short, or a switch that was actually a hub running at 10/100 half-duplex.

Until now it is known that the Pi3B+ connected with a cable to an unknown switch with another cable to an unknown device appears to work but it does not if the Pi3B+ is connected with a direct cable to the unknown device.

Re: problems with stretch static ip dhcpcd

Posted: Wed Jul 25, 2018 6:15 am
by shivaVMC
Ernst wrote:
Mon Jul 23, 2018 6:20 am
1) Identify Rpi, is it something you can eat ?
2) Identify "my board", is it something you made yourself ?
3) Try another LAN cable
4) Try another LAN cable, in this case an X-over cable
5) Cut cable used in 3) and count the number of wires, if 4 wires then try cable with 8, if 8 wires try cable with 4 (maybe x-over needed)

I have checked with all possibilities as 8Wire straight cable's ,8wire cross cable,4wire straight cable,4wire Cross Cable...But ethernet Link has not detected.
No Improvement I found .Ethernet link itself is not up from Raspberry->Mydevice
But link is of Rpi is UP when I connect from Rpi to My Laptop.

Re: problems with stretch static ip dhcpcd

Posted: Wed Jul 25, 2018 6:44 am
by Ernst
shivaVMC wrote:
Wed Jul 25, 2018 6:15 am
Ernst wrote:
Mon Jul 23, 2018 6:20 am
1) Identify Rpi, is it something you can eat ?
2) Identify "my board", is it something you made yourself ?
3) Try another LAN cable
4) Try another LAN cable, in this case an X-over cable
5) Cut cable used in 3) and count the number of wires, if 4 wires then try cable with 8, if 8 wires try cable with 4 (maybe x-over needed)

I have checked with all possibilities as 8Wire straight cable's ,8wire cross cable,4wire straight cable,4wire Cross Cable...But ethernet Link has not detected.
No Improvement I found .Ethernet link itself is not up from Raspberry->Mydevice
But link is of Rpi is UP when I connect from Rpi to My Laptop.
Why did you not test Laptop->Mydevice ?

This is my last reply: The device "Mydevice", sometimes called "board" or "My board", which you have been unwilling to identify, is the first problem, you are the second problem hijacking a thread, by not giving clear answers on questions, and using different names for the same thing in the same post.

Re: problems with stretch static ip dhcpcd

Posted: Wed Jul 25, 2018 6:53 am
by shivaVMC
From Laptop-Mydevice is working fine.

But,Rpi->Mydevice not working why why why...!!!?

Mydevice=board=Myboard nothing but the same...Sorry for multiple names to myboard.