Mary2018
Posts: 11
Joined: Sat Feb 03, 2018 9:31 am

Raspbian Stretch With Desktop - 11/29/2017

Wed Feb 14, 2018 8:15 pm

I downloaded the "Raspbian Stretch With Desktop - 11/29/2017". I can not connect the rasp pi3 to my wifi network. With the Jessie version everything worked normally. Any tips? thanks!

User avatar
HawaiianPi
Posts: 2343
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Raspbian Stretch With Desktop - 11/29/2017

Wed Feb 14, 2018 8:27 pm

How are you attempting the connection, what encryption is your router using, and what trouble are you having (error messages, etc.)? We need details in order to help you.

Based on what little information you did supply, I'm guessing your wpa_supplicant.conf file looks like this:

Code: Select all

network={
	ssid="Your network SSID"
	psk="Your WPA/WPA2 security key"
}
When it should look like this:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
	ssid="Your network SSID"
	psk="Your WPA/WPA2 security key"
	key_mgmt=WPA-PSK
}
The minimal version worked with Jessie, but not with Stretch.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

Mary2018
Posts: 11
Joined: Sat Feb 03, 2018 9:31 am

Re: Raspbian Stretch With Desktop - 11/29/2017

Wed Feb 14, 2018 8:53 pm

HawaiianPi wrote:
Wed Feb 14, 2018 8:27 pm
How are you attempting the connection, what encryption is your router using, and what trouble are you having (error messages, etc.)? We need details in order to help you.

Based on what little information you did supply, I'm guessing your wpa_supplicant.conf file looks like this:

Code: Select all

network={
	ssid="Your network SSID"
	psk="Your WPA/WPA2 security key"
}
When it should look like this:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
	ssid="Your network SSID"
	psk="Your WPA/WPA2 security key"
	key_mgmt=WPA-PSK
}
The minimal version worked with Jessie, but not with Stretch.
Thank you! But I'm using the Stretch. My problem is Stretch :-(

pcmanbob
Posts: 3892
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Raspbian Stretch With Desktop - 11/29/2017

Wed Feb 14, 2018 10:44 pm

Try reading what HawaiianPi wrote.

He is telling you that with Jessie you could get away with the short data entry in wpa_supplicant.conf
But in STRETCH you you need to use the full/long data entry in your wpa_supplicant.conf

So Stretch needs the longer wpa_supplicant.conf, have you used this version of the wpa_supplicant.conf ?
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

Mary2018
Posts: 11
Joined: Sat Feb 03, 2018 9:31 am

Re: Raspbian Stretch With Desktop - 11/29/2017

Thu Feb 15, 2018 12:38 pm

pcmanbob wrote:
Wed Feb 14, 2018 10:44 pm
Try reading what HawaiianPi wrote.

He is telling you that with Jessie you could get away with the short data entry in wpa_supplicant.conf
But in STRETCH you you need to use the full/long data entry in your wpa_supplicant.conf

So Stretch needs the longer wpa_supplicant.conf, have you used this version of the wpa_supplicant.conf ?
Thanks! Yes, but didn't work :-(

pcmanbob
Posts: 3892
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Raspbian Stretch With Desktop - 11/29/2017

Thu Feb 15, 2018 12:59 pm

Mary2018 wrote:
Thu Feb 15, 2018 12:38 pm
pcmanbob wrote:
Wed Feb 14, 2018 10:44 pm
Try reading what HawaiianPi wrote.

He is telling you that with Jessie you could get away with the short data entry in wpa_supplicant.conf
But in STRETCH you you need to use the full/long data entry in your wpa_supplicant.conf

So Stretch needs the longer wpa_supplicant.conf, have you used this version of the wpa_supplicant.conf ?
Thanks! Yes, but didn't work :-(

Then I suggest you post the contents of your wpa_supplicant.conf file so we can look at it and may be we can spot an error/typo.

also do not use a document editor like word on windows to create/edit your file as it inserts hidden characters.
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

Mary2018
Posts: 11
Joined: Sat Feb 03, 2018 9:31 am

Re: Raspbian Stretch With Desktop - 11/29/2017

Thu Feb 15, 2018 4:05 pm

pcmanbob wrote:
Thu Feb 15, 2018 12:59 pm
Mary2018 wrote:
Thu Feb 15, 2018 12:38 pm
pcmanbob wrote:
Wed Feb 14, 2018 10:44 pm
Try reading what HawaiianPi wrote.

He is telling you that with Jessie you could get away with the short data entry in wpa_supplicant.conf
But in STRETCH you you need to use the full/long data entry in your wpa_supplicant.conf

So Stretch needs the longer wpa_supplicant.conf, have you used this version of the wpa_supplicant.conf ?
Thanks! Yes, but didn't work :-(

Then I suggest you post the contents of your wpa_supplicant.conf file so we can look at it and may be we can spot an error/typo.

also do not use a document editor like word on windows to create/edit your file as it inserts hidden characters.
Hi! I attached my file, I used Notepad++.
To attach the file, I had to save it as an image. But I have it as wpa_supplicant.conf.
Thanks a lot!! ;-)
Attachments
wpa_supplicant.jpg
wpa_supplicant.jpg (77.39 KiB) Viewed 1014 times

pcmanbob
Posts: 3892
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Raspbian Stretch With Desktop - 11/29/2017

Thu Feb 15, 2018 4:12 pm

Well it looks OK to me , you could try setting the country code to GB and trying again some people who were having problems connecting found this solved it, I would also recommend rebooting your router just in case the router has locked up in some way with all you attempts to connect.
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

Mary2018
Posts: 11
Joined: Sat Feb 03, 2018 9:31 am

Re: Raspbian Stretch With Desktop - 11/29/2017

Thu Feb 15, 2018 7:51 pm

pcmanbob wrote:
Thu Feb 15, 2018 4:12 pm
Well it looks OK to me , you could try setting the country code to GB and trying again some people who were having problems connecting found this solved it, I would also recommend rebooting your router just in case the router has locked up in some way with all you attempts to connect.
Ok! I will try ;-) Thank you!

User avatar
davidcoton
Posts: 2958
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: Raspbian Stretch With Desktop - 11/29/2017

Thu Feb 15, 2018 11:08 pm

Does your network hide its ssid? If so, add a line as follows:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=BR

network={
	ssid="YVirus"
	psk="my password here"
	scan_ssid=1
	key_mgmt=WPA-PSK
}
The other possibility is that you network is not running WPA security?
"Thanks for saving my life." See https://www.raspberrypi.org/forums/viewtopic.php?p=1327656#p1327656
“Raspberry Pi is a trademark of the Raspberry Pi Foundation”

Mary2018
Posts: 11
Joined: Sat Feb 03, 2018 9:31 am

Re: Raspbian Stretch With Desktop - 11/29/2017

Fri Feb 16, 2018 1:34 pm

davidcoton wrote:
Thu Feb 15, 2018 11:08 pm
Does your network hide its ssid? If so, add a line as follows:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=BR

network={
	ssid="YVirus"
	psk="my password here"
	scan_ssid=1
	key_mgmt=WPA-PSK
}
The other possibility is that you network is not running WPA security?
My network running WPA.
"...SSID: Virus
Protocol: 802.11n
Security type: WPA2-Personal WPA-PSK
Network band: 2.4 GHz..."

dgordon42
Posts: 740
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: Raspbian Stretch With Desktop - 11/29/2017

Sat Feb 17, 2018 11:31 am

@Mary2018:
With your 'wpa_supplicant.conf' file open in Notepad++, check the status line at the bottom. Where it says "Windows (CR LF)", right click and select "Unix (LF)" instead. Then re-save your file on the RaspberryPi.
Windows and Linux (Unix) store their 'End Of Line' symbols differently in text files, and this can cause problems when moving text files between Operating Systems.

Hope this helps,
Dave.

pcmanbob
Posts: 3892
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Raspbian Stretch With Desktop - 11/29/2017

Sat Feb 17, 2018 11:45 am

As the OP stated they are using notpad++ you can set the line ending format to be unix (LF) for all new files.

by selecting preferences > new document > format line ending.

for existing files you can do EOL conversion by selecting Edit>EOL conversion>then selecting unix (LF) >then re-save the file.
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

dgordon42
Posts: 740
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: Raspbian Stretch With Desktop - 11/29/2017

Sat Feb 17, 2018 1:31 pm

pcmanbob wrote:As the OP stated they are using notpad++ you can set the line ending format to be unix (LF) for all new files.

by selecting preferences > new document > format line ending.

for existing files you can do EOL conversion by selecting Edit>EOL conversion>then selecting unix (LF) >then re-save the file.
In the OP's attachment above, their 'wpa_supplicant.conf' file is shown in Notepad++, but the file type is set to Windows, so I doubt the file will be read correctly by the Pi without converting it to a Unix format as suggested here.

Dave.

User avatar
HawaiianPi
Posts: 2343
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Raspbian Stretch With Desktop - 11/29/2017

Sat Feb 17, 2018 1:39 pm

I don't have any trouble with wpa_supplicant.conf or config.txt files created or edited with regular Windows Notepad, so I doubt that's the problem here. It certainly won't hurt to use Notepad++ with Unix LF EOL settings, but I'd be surprised if that helps.

From other posts I've seen the problem may be related to the type of quotes. Some so-called "text editors" replace the standard quotes with curly quotes and that invalidates the wpa_supplicant.conf file. That can also happen if you copied and pasted the contents from a web page.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

pcmanbob
Posts: 3892
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Raspbian Stretch With Desktop - 11/29/2017

Sat Feb 17, 2018 1:45 pm

If it were me I would delete the existing file and after setting the EOL format I would type in all the settings again, I use notepad++ to create/edit config files for Linux so I now it uses the correct type of quotes so that should remove 2 possible causes in one stroke.
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

Mary2018
Posts: 11
Joined: Sat Feb 03, 2018 9:31 am

Re: Raspbian Stretch With Desktop - 11/29/2017

Tue Feb 20, 2018 11:30 am

dgordon42 wrote:
Sat Feb 17, 2018 11:31 am
@Mary2018:
With your 'wpa_supplicant.conf' file open in Notepad++, check the status line at the bottom. Where it says "Windows (CR LF)", right click and select "Unix (LF)" instead. Then re-save your file on the RaspberryPi.
Windows and Linux (Unix) store their 'End Of Line' symbols differently in text files, and this can cause problems when moving text files between Operating Systems.

Hope this helps,
Dave.
Thanks! I will try ;-)

Mary2018
Posts: 11
Joined: Sat Feb 03, 2018 9:31 am

Re: Raspbian Stretch With Desktop - 11/29/2017

Tue Feb 20, 2018 12:14 pm

pcmanbob wrote:
Thu Feb 15, 2018 4:12 pm
Well it looks OK to me , you could try setting the country code to GB and trying again some people who were having problems connecting found this solved it, I would also recommend rebooting your router just in case the router has locked up in some way with all you attempts to connect.
I did everything you recommended, but it did not work. Thank you!

Mary2018
Posts: 11
Joined: Sat Feb 03, 2018 9:31 am

Re: Raspbian Stretch With Desktop - 11/29/2017

Tue Feb 20, 2018 12:21 pm

Mary2018 wrote:
Tue Feb 20, 2018 11:30 am
dgordon42 wrote:
Sat Feb 17, 2018 11:31 am
@Mary2018:
With your 'wpa_supplicant.conf' file open in Notepad++, check the status line at the bottom. Where it says "Windows (CR LF)", right click and select "Unix (LF)" instead. Then re-save your file on the RaspberryPi.
Windows and Linux (Unix) store their 'End Of Line' symbols differently in text files, and this can cause problems when moving text files between Operating Systems.

Hope this helps,
Dave.
Thanks! I will try ;-)
I did everything you recommended, but it did not work. Please see the step by step I did.
Attachments
forum_02202018.jpg
forum_02202018.jpg (247.73 KiB) Viewed 727 times
01.jpg
01.jpg (33.81 KiB) Viewed 727 times

pcmanbob
Posts: 3892
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: Raspbian Stretch With Desktop - 11/29/2017

Tue Feb 20, 2018 12:59 pm

Have you during any of this tried rebooting your router and the pi ?

turn pi off reboot router give it time to complete its setup and then power pi and see then if it will connect.

if it does not connect, log on to your router and check what wifi security you have set.
Remember we want information.......................no information no help
The use of crystal balls & mind reading is not supported

Mary2018
Posts: 11
Joined: Sat Feb 03, 2018 9:31 am

Re: Raspbian Stretch With Desktop - 11/29/2017

Tue Feb 20, 2018 3:49 pm

pcmanbob wrote:
Tue Feb 20, 2018 12:59 pm
Have you during any of this tried rebooting your router and the pi ?

turn pi off reboot router give it time to complete its setup and then power pi and see then if it will connect.

if it does not connect, log on to your router and check what wifi security you have set.
Ok! I will test.

Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 67 guests