Invincer
Posts: 4
Joined: Thu Jan 05, 2017 7:57 am

Tried steps for setting Pi 3 to boot up from USB HD, not working though

Sun Jan 28, 2018 5:32 pm

Went through all the steps on webpage https://www.raspberrypi.org/documentati ... des/msd.md. Tried it 3 times. But when I take out the SD card and try to boot from the USD (which is a WD PiDrive Foundation Edition 375GB), all I get is the black screen with the following three lines...

[ 0.350021] bcm2835-aux-uart 3f21540.serial: could not get clk: -517
[ 3.607219] sd 0:0:0:0: [sda] No Caching mode page found
[ 3.612789] sd 0:0:0:0: [sda] Assuming drive cache: write through

after those three lines it just hangs stopping there doing nothing...

Any help would be GREATLY appreciated. If I need to put a small 4 gb sd card in to boot I am fine with that, if so what or how should I put the boot dir in there. Is there some simple command the pi documentation missed in order to get this to work? Thanks for any and all help.

k-pi
Posts: 927
Joined: Sun Feb 12, 2017 1:46 pm
Location: Upper Hale, Surrey, UK.

Re: Tried steps for setting Pi 3 to boot up from USB HD, not working though

Sun Jan 28, 2018 7:57 pm

Did you check that the OTP bit was set correctly, & did you reboot with the card in place once more before trying to boot from USB.

Invincer
Posts: 4
Joined: Thu Jan 05, 2017 7:57 am

Re: Tried steps for setting Pi 3 to boot up from USB HD, not working though

Sun Jan 28, 2018 8:03 pm

Thanks for the reply!

I did the otp check

$ vcgencmd otp_dump | grep 17:
17:3020000a

have since used it a few times with both the sd card and usb in it mainly because the usb boot doesnt work

k-pi
Posts: 927
Joined: Sun Feb 12, 2017 1:46 pm
Location: Upper Hale, Surrey, UK.

Re: Tried steps for setting Pi 3 to boot up from USB HD, not working though

Mon Jan 29, 2018 12:51 pm

Maybe try with a pendrive to check it works.

Then, if that works, it could be a power problem, (the RPi3B needs at least a 2.4amp power supply).

User avatar
piglet
Posts: 909
Joined: Sat Aug 27, 2011 1:16 pm

Re: Tried steps for setting Pi 3 to boot up from USB HD, not working though

Mon Jan 29, 2018 1:10 pm

Hi,

I had similar problems when trying to do this with a WD PiDrive - see here: viewtopic.php?f=28&t=194802

In the end I never managed to get a reliable boot (maybe 1 in 10 worked), and resorted to leaving a card in the pi pointing to the mountpoints on the drive.

It's a shame really.

n67
Posts: 938
Joined: Mon Oct 30, 2017 4:55 pm

Re: Tried steps for setting Pi 3 to boot up from USB HD, not working though

Mon Jan 29, 2018 1:32 pm

piglet wrote:
Mon Jan 29, 2018 1:10 pm
Hi,

I had similar problems when trying to do this with a WD PiDrive - see here: viewtopic.php?f=28&t=194802

In the end I never managed to get a reliable boot (maybe 1 in 10 worked), and resorted to leaving a card in the pi pointing to the mountpoints on the drive.

It's a shame really.
Yeah. That's the best way to do it.
"L'enfer, c'est les autres"

G fytc hsqr rum umpbq rm qyw rm rfc kmbq md rfgq dmpsk:

Epmu Sn!

J lnacjrw njbruh-carppnanm vxm rb mnuncrwp vh yxbcb!

User avatar
HawaiianPi
Posts: 4616
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Tried steps for setting Pi 3 to boot up from USB HD, not working though

Mon Jan 29, 2018 8:09 pm

Invincer wrote:
Sun Jan 28, 2018 8:03 pm
I did the otp check

$ vcgencmd otp_dump | grep 17:
17:3020000a

have since used it a few times with both the sd card and usb in it mainly because the usb boot doesnt work
What are you using for a power supply?

How did you get the OS on the PiDrive?

Did you check cmdline.txt to ensure that it's pointing root at the PiDrive root partition (by UUID or PART-UUID preferably)?

In cmdline.txt you should see something like root=PARTUUID=1234abcd-02
You can check the PART-UUID of your drives with

Code: Select all

ls /dev/disk/by-partuuid -lt
Invincer wrote:
Sun Jan 28, 2018 5:32 pm
[ 0.350021] bcm2835-aux-uart 3f21540.serial: could not get clk: -517
That's an odd error, and not caused by anything needed for USB boot. What other changes have you made to the system configuration?

Invincer wrote:
Sun Jan 28, 2018 5:32 pm
If I need to put a small 4 gb sd card in to boot I am fine with that, if so what or how should I put the boot dir in there.
Format the SD card with the FAT32 file system and copy the contents of the "boot" partition to it (the "boot" partition is small FAT32 partition that should be the first partition on a Raspbian imaged SD card or USB drive, labelled "boot").

You could also try grabbing the next branch bootcode.bin from GitHub and put that, and only that on the FAT32 formatted SD card. Works reliably if your boot drive is the only USB storage device. If you have more than one USB storage device connected bootcode.bin might fail, since it only attempts to boot the first device it finds.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

Return to “Troubleshooting”