redlinesprint
Posts: 12
Joined: Sat Dec 01, 2018 7:36 pm

Re: pi zero w wpa_supplicant

Tue Dec 04, 2018 3:24 am

Power supply is a ipad brick. When I deleted the suggested files in interfaces and changed us to US and ran

Code: Select all

sudo ifconfig wlan0
it returned:
lo: flags=73<UO, LOOPBACK,RUNNING> mtu 65536
inet 127.0.01 netmask 255.0.0.0
buncha other rx and tx info

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether (hex code) txqueuelen 1000 (Ethernet)
rx and tx info but no internet info.

I think I will try to reflash the drive again and get it running on the pi3 then move it to the ZeroW again. Trying to keep a free port on my switch hence the desire for wifi.

Open to other troubleshooting still.

redlinesprint
Posts: 12
Joined: Sat Dec 01, 2018 7:36 pm

Re: pi zero w wpa_supplicant

Tue Dec 04, 2018 5:00 pm

So time for an update. I started from scratch 100% again. Fresh image of Stretch lite, and burned it to the card using etcher. I then opened notepad++ and copied the wpa_supplicant code from HawaiianPi and put it on the boot partition like I had before. Made sure it was a .conf file as well. Also added the ssh file as well because why not and ran it right from the pi zero w.

well this time it worked. I must have typed the code wrong somehow even after trying all the suggestions from this post and reverting back to the suggested configurations.

Once I confirmed it was working properly I formatted the card and installed UnifiPi (based off of stretch lite) and used the same wpa_supplicant.conf file and ssh file and it worked as well!

So now that I have that working... how should I change the wpa_supplicant.conf file to have 2 network connections but prefer one over the other?

DirkS
Posts: 9901
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: pi zero w wpa_supplicant

Tue Dec 04, 2018 5:31 pm

redlinesprint wrote:
Tue Dec 04, 2018 5:00 pm
So now that I have that working... how should I change the wpa_supplicant.conf file to have 2 network connections but prefer one over the other?
Just add another network block.
Add 'priority' parameter to each block. NB: higher value means higher priority (so the system will choose

Code: Select all

network={
  ssid="ssid"
  psk="passkey"
  priority=10
}

redlinesprint
Posts: 12
Joined: Sat Dec 01, 2018 7:36 pm

Re: pi zero w wpa_supplicant

Tue Dec 04, 2018 5:54 pm

Ok easy enough. Any recommended priority numbers?

DirkS
Posts: 9901
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: pi zero w wpa_supplicant

Tue Dec 04, 2018 6:18 pm

redlinesprint wrote:
Tue Dec 04, 2018 5:54 pm
Any recommended priority numbers?
Not really, but I would leave gaps in case you want to add some APs with minimal editing.

redlinesprint
Posts: 12
Joined: Sat Dec 01, 2018 7:36 pm

Re: pi zero w wpa_supplicant

Tue Dec 04, 2018 6:20 pm

Sounds like good advice. Will it automatically switch access points once configured or do i have to restart the pi?

Return to “Troubleshooting”