sudopiroot
Posts: 8
Joined: Mon Jan 22, 2018 7:33 pm

raspberry pi zero w headless set up - SOLVED

Mon Jan 22, 2018 8:00 pm

I'm having trouble getting my first raspberry pi zero w set up!

I cannot see the pi on my network.

ssh and wpa_supplicant.conf have both been dropped into /boot

contents of wpa_supplicant.conf

Code: Select all

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
 ssid="Range2.5x"
 psk="password"
 key_mgmt=WPA-PSK
}
any suggestions?
Last edited by sudopiroot on Tue Jan 23, 2018 5:40 am, edited 1 time in total.

klricks
Posts: 5681
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: raspberry pi zero w headless set up

Tue Jan 23, 2018 5:06 am

sudopiroot wrote:
Mon Jan 22, 2018 8:00 pm
.....ssh and wpa_supplicant.conf have both been dropped into /boot...
The files go into the root level of the SD card. NOT in /boot
When successful the files will be automatically deleted on RPi boot.
So if you put the SD card back into the PC and the 2 files have disappeared, then you know that ssh is enabled and the WPA file was moved to the proper location. (Doesn't however necessarily mean that the content of the WPA file is correct).

Note the the root level of the SD card becomes /boot when booted in the RPi but when read in a Windows or MAC it is at the root level.

Also you must be using the standalone version of Raspbian..... NOT NOOBs.
Unless specified otherwise my response is based on the latest and fully updated Raspbian Stretch w/ Desktop OS.

sudopiroot
Posts: 8
Joined: Mon Jan 22, 2018 7:33 pm

Re: raspberry pi zero w headless set up

Tue Jan 23, 2018 5:38 am

klricks wrote:
Tue Jan 23, 2018 5:06 am
sudopiroot wrote:
Mon Jan 22, 2018 8:00 pm
.....ssh and wpa_supplicant.conf have both been dropped into /boot...
The files go into the root level of the SD card. NOT in /boot
When successful the files will be automatically deleted on RPi boot.
So if you put the SD card back into the PC and the 2 files have disappeared, then you know that ssh is enabled and the WPA file was moved to the proper location. (Doesn't however necessarily mean that the content of the WPA file is correct).

Note the the root level of the SD card becomes /boot when booted in the RPi but when read in a Windows or MAC it is at the root level.

Also you must be using the standalone version of Raspbian..... NOT NOOBs.
I'm using a Mac so I really meant to say /Volumes/boot (which is in fact the root directory, sorry about that).

yes, I have the latest stretch image

however, I'm really dumb and accidentally did not capitalize the "x" in my network name :oops: :evil: :lol:

thank you so much for reaching out, but I'm afraid we would've never gotten this one solved if I hadn't realized how stupid I am :lol:

Return to “Troubleshooting”

Who is online

Users browsing this forum: davidcoton and 39 guests