Page 1 of 1

unmet dependencies python3-apt Depends: libapt-inst2.0 but 1.8.22-0+deb8u1 is installed

Posted: Fri Jan 19, 2018 12:33 pm
by nater658
I'm losing my mind over this. I found a similar case but it wasn't resolved either. I've just upgraded from Jessie to Stretch. There are some dependency issues preventing python3.

Autoremove does nothing.
apt-get-f install does nothing.

What do I do?

[email protected]:/home/nate# apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
python3-apt : Depends: libapt-inst2.0 (>= 1.4~beta3) but it is not installed
Depends: libapt-pkg5.0 (>= 1.4~beta3) but it is not installed
Depends: libstdc++6 (>= 5.2) but 4.9.2-10 is installed
python3-dbus : Depends: libdbus-1-3 (>= 1.9.14) but 1.8.22-0+deb8u1 is installed
E: Unmet dependencies. Try using -f.