RlTA
Posts: 1
Joined: Thu Jan 18, 2018 11:48 pm
Contact: Website

Zero W WiFi unable to use wpa_supplicant

Fri Jan 19, 2018 4:05 am

I recently bought a zero w and flashed an sd card with the latest raspbian.
I was able to boot up the system with no problems at all, but as soon as I tried to get this connected to a Wi-Fi network, the wpa_supplicant would not work properly and scan any APs.
I tried different versions of raspbian and I even used volumio, but these did not solve the issue.
I attached a file that I used for the wpa_supplicant.conf and the prompt output of the command below.

Code: Select all

sudo wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -i wlan0 -Dnl80211,wext -dd
One thing I noticed from the prompt output is that the wpa_supplicant actually makes a WPA Handshake with the AP successfully, and then gets a deauth from local reason for somehow.
I do not know if this is a hardware problem or a software problem, but from hours of googling, I am starting to think that the one I received from Argon40 is a defective one.

Any help would be appreciated.


+ the /proc/cpuinfo tells me the correct Serial and cpu/board information
Attachments
Documents.zip
(7.36 KiB) Downloaded 7 times
Using: RPi Zero W
Odroid C2

User avatar
neilgl
Posts: 167
Joined: Sun Jan 26, 2014 8:36 pm
Location: Near Aston Martin factory

Re: Zero W WiFi unable to use wpa_supplicant

Sat Jan 20, 2018 12:19 am

Ah, I copy a wpa_supplicant file to the "boot" partition of the SD card from my pc after using win32diskimager (or etcher) for pi zero W
Then it works on wifi. This is what is in that file:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=UK

network={
	ssid="YourSSID"
	psk="YourPASSPHRASE"
	key_mgmt=WPA-PSK
}

Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 47 guests