NewtownGal
Posts: 29
Joined: Fri Jul 01, 2016 1:26 pm

minicom not finding /dev/modem on Pi-Zero

Thu Jan 18, 2018 7:53 pm

I'm having trouble using minicom 2.6.1 (latest) with a USB cell modem and Raspian Wheezy on a Pi-Zero, whereas the identical configuration works fine on Pi-B+ and Pi-2.

To use minicom, one sets a symlink from /dev/ttyUSBx to /dev/modem. On the machines that work, if I leave out this symlink, then when I try to start minicom, it refuses to start, saying:

Code: Select all

minicom: cannot open /dev/modem: No such file or directory
This is as it should be. And, on the machines that work, when I provide a symlink, and I try to run minicom, minicom reports:

Code: Select all

OPTIONS: I18n
Compiled on Apr 28 2012, 19:24:31.
Port /dev/modem
This is as it should be. I can control the modem using AT commands.

But when I try to run this same version of minicom on a Pi-Zero, using the same OS and USB cell modem, without a symlink for /dev/modem, minicom starts and reports Port /dev/tty8. When I provide a symlink, minicom ignores it.

The result is that I can't use minicom on a Pi-Zero to control my modem. I don't see why it should be machine-specific, and I can't find any differences in configuration that explain this problem. I tried setting the path to the modem in the configuration settings in minicom, to no avail.

Can someone tell me how to get minicom to work with the usual symlink on a Pi-Zero ?

Thank you.

User avatar
topguy
Posts: 4013
Joined: Tue Oct 09, 2012 11:46 am
Location: Trondheim, Norway

Re: minicom not finding /dev/modem on Pi-Zero

Thu Jan 18, 2018 10:35 pm

You can start minicom with "-s" option at it will take you directly to the config menu where you can setup device name, baud rates etc.
( The same config menus can be reached with the CTRL-A command CTRL-A, O )
You can also store named profiles that you can later start minicom with automatically. The profile "dfl" is loaded if you dont specify a profile as a parameter to minicom )
You usually have to start minicom with sudo to get access to the profiles saved in /etc/minicom

Do Raspbian Wheezy even have PiZero support ?

NewtownGal
Posts: 29
Joined: Fri Jul 01, 2016 1:26 pm

Re: minicom not finding /dev/modem on Pi-Zero

Fri Jan 19, 2018 2:38 am

I'm running 4.9.40+ #1022 on the Pi-Zero.

I tried minicom -s on the Pi-Zero before making my initial post. No dice. It appears to accept a change in the serial port setup, but AT commands don't work. But that begs the issue, why does the same version of minicom run differently on a Pi-Zero than a Pi-B+ and a Pi-2 ? What is machine dependent in minicom ? Is there a configuration setting somewhere that makes the difference in minicom ?

User avatar
scruss
Posts: 1511
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: minicom not finding /dev/modem on Pi-Zero

Fri Jan 19, 2018 4:45 am

check if you're a member of the dialout group. Serial is difficult without that.

you don't need the symlink. I typically call minicom with:

Code: Select all

minicom -D /dev/ttyUSBx -b 57600
or similar
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

NewtownGal
Posts: 29
Joined: Fri Jul 01, 2016 1:26 pm

Re: minicom not finding /dev/modem on Pi-Zero

Fri Jan 19, 2018 4:20 pm

Thank you. Using the following as root:

Code: Select all

minicom -D /dev/ttyUSB3 
works and it replies:

Code: Select all

Welcome to minicom 2.6.1

OPTIONS: I18n
Compiled on Apr 24 2017, 22:21:17.
Port /dev/ttyUSB3
I still don't know why there's a difference in how minicom runs, but I can communicate with the modem, which is all I care about.

User avatar
scruss
Posts: 1511
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: minicom not finding /dev/modem on Pi-Zero

Sat Jan 20, 2018 2:14 am

if you were a member of dialout you wouldn't need to be root. You should be if you're running Stretch
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

Return to “Troubleshooting”

Who is online

Users browsing this forum: Google [Bot], NathanielJS and 56 guests