Page 1 of 1

Can't connect my Raspberry Pi Zero W to my house router.

Posted: Thu Jan 18, 2018 8:39 am
by javier.vela
I have a brand new raspi zero w and im not able to find my routers SSID in the WIFI settings. Otherwise, I can connect to any other WIFI in the building but mine. I dont know what is the problem but creating an AP with my phone and sharing my data allows me to connect my raspberry to the internet. Does anyone now why my router is not shown? Ive always been able to connect any device to it. The router model is Comtrend VG-8050. Thank you!

Re: Can't connect my Raspberry Pi Zero W to my house router.

Posted: Thu Jan 18, 2018 12:44 pm
by pcmanbob
Hi.

If you pi can see all the other wifi services in the building and the one on your phone then I would say the problem lies with your router, may be its been set up not to broadcast the ssid.

Re: Can't connect my Raspberry Pi Zero W to my house router.

Posted: Thu Jan 18, 2018 1:34 pm
by klricks
Make sure the router is set to 2.4GHz or mixed. The RPi does not do 5GHz.

Re: Can't connect my Raspberry Pi Zero W to my house router.

Posted: Thu Jan 18, 2018 1:46 pm
by rurwin
Also make sure that the Pi Zero is configured for the country it is working in. Some of the channels are disabled by default (because they are not available in the USA) and your router may be using one of those.

If you've got an Android phone, there's a useful app called WiFi Analyzer that shows you graphically what local WiFi networks are working on which channels. I don't believe it is available on iPhones though.

Re: Can't connect my Raspberry Pi Zero W to my house router.

Posted: Fri Jan 19, 2018 5:32 pm
by DougieLawson
Make sure the access point is using WPA or WPA2 (NOT WEP) security. It's a pain in the tail to configure WEP (which is 100% insecure anyway).

Re: Can't connect my Raspberry Pi Zero W to my house router.

Posted: Wed Jan 31, 2018 11:02 am
by javier.vela
Thank you I was able to solve the problem by changing the country, I don't know why it was set by default to UK.

Re: Can't connect my Raspberry Pi Zero W to my house router.

Posted: Wed Jan 31, 2018 11:35 am
by davidcoton
javier.vela wrote:I don't know why it was set by default to UK.
Pi is a British product. Why would it not be set to UK by default?

Re: Can't connect my Raspberry Pi Zero W to my house router.

Posted: Wed Jan 31, 2018 12:29 pm
by drgeoff
javier.vela wrote:
Wed Jan 31, 2018 11:02 am
Thank you I was able to solve the problem by changing the country, I don't know why it was set by default to UK.
That does not make sense as the reason why it did not work. The UK permits all 1 to 13 channels of 2.4GHz. Japan permits the 14th but restricted to 802.11b. The US is channels 1 to 11.

Re: Can't connect my Raspberry Pi Zero W to my house router.

Posted: Wed Jan 31, 2018 1:37 pm
by rurwin
I've certainly had to change the country to the UK before now. It may be that it is unassigned by default so that, wherever it is used, it uses the minimum legal allocation. (Israel doesn't allow channels 1-4 outdoors.) The config utility might show the UK first on the basis that lots of people want it and it's otherwise a pain to scroll down. That would make it look like it was already set to the UK.