hippy
Posts: 7127
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

[SOLVED] python-scrollphathd upgrade problem

Sun Jan 14, 2018 9:01 pm

Just doing my weekly sudo apt-get update/upgrade on my Pi 3B and got this ...

Code: Select all

Unpacking python-scrollphathd (1.1.0) over (1.0.1) ...
Preparing to unpack .../5-python3-scrollphathd_1.1.0_all.deb ...
Unpacking python3-scrollphathd (1.1.0) over (1.0.1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-penvD7/5-python3-scrollphathd_1.1.0_all.deb (--unpack):
 trying to overwrite '/usr/bin/scrollphathd_api', which is also in package python-scrollphathd 1.1.0
Errors were encountered while processing:
 /tmp/apt-dpkg-install-penvD7/5-python3-scrollphathd_1.1.0_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~$                                            
I unsurprisingly now get this error every time I upgrade. Not quite sure what the error or issue is. I'm logged in as the Pi user, am using sudo apt-get upgrade, the file it seems to be trying to overwrite exists ...

Code: Select all

[email protected]:~$ ls -l /usr/bin/scrollphathd_api
-rwxr-xr-x 1 root root 414 Jan 11 11:25 /usr/bin/scrollphathd_api 
Tried renaming ''/usr/bin/scrollphathd_api" to something else, but still get the same error.

Any idea how I fix whatever the issue is or make the error when I upgrade go away ?
Last edited by hippy on Mon Jan 15, 2018 12:08 am, edited 1 time in total.

cjan
Posts: 810
Joined: Sun May 06, 2012 12:00 am

Re: python-scrollphathd upgrade problem

Sun Jan 14, 2018 10:03 pm

same here +1.

DavidMS
Posts: 139
Joined: Fri May 25, 2012 8:48 pm
Contact: Website

Re: python-scrollphathd upgrade problem

Sun Jan 14, 2018 10:19 pm

same for me, interestingly if you do an apt-get install it will finish off the aborted update when it has installed the new application which I guess makes sense
http://meanderingpi.wordpress.com/
11 Raspberry Pi's and counting....

User avatar
DougieLawson
Posts: 38489
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: python-scrollphathd upgrade problem

Sun Jan 14, 2018 10:51 pm

cd /var/cache/apt/archives
sudo dpkg -i --force-overwrite python3-scrollphathd_1.1.0_all.deb


It's a bit crude but resolves the problem. No idea why we need that package in a standard Raspbian install since it's for special hardware.
Last edited by DougieLawson on Mon Jan 15, 2018 11:09 pm, edited 1 time in total.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

User avatar
davidcoton
Posts: 4772
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK
Contact: Website

Re: python-scrollphathd upgrade problem

Sun Jan 14, 2018 11:37 pm

DougieLawson wrote: No idea why we need that package in a standard Raspbian install since it's for special hardware.
Two possible reasons:
  1. Mistake :o :shock: :?
  2. Preparation for h/w built in to imminent Pi4B :twisted:
Signature retired

hippy
Posts: 7127
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

Re: python-scrollphathd upgrade problem

Mon Jan 15, 2018 12:03 am

DavidMS wrote:
Sun Jan 14, 2018 10:19 pm
same for me, interestingly if you do an apt-get install it will finish off the aborted update when it has installed the new application which I guess makes sense
I couldn't figure out how you exactly meant by "apt-get install". Without any package name ? I tried "sudo apt-get install python3-scrollphathd" but got the same error. But this worked -

sudo apt-get remove python3-scrollphathd

So I then did -

sudo apt-get remove python-scrollphathd

Everything seems to be working now and I've got a little more disk space.
davidcoton wrote:
Sun Jan 14, 2018 11:37 pm
  1. Mistake :o :shock: :?
  2. Preparation for h/w built in to imminent Pi4B :twisted:
It is coming up to the launch anniversary date so we can let the speculation run free. My guess would be -

Free Scroll pHAT HD with the March MagPi.
Pimoroni are preparing a Zero WH plus Scroll pHAT HD bundle.

John Mc
Posts: 47
Joined: Wed Feb 22, 2017 1:22 am

Re: python-scrollphathd upgrade problem

Mon Jan 15, 2018 5:17 am

DougieLawson wrote:
Sun Jan 14, 2018 10:51 pm
cd /var/cache/apt/archive
sudo dpkg -i --force-overwrite python3-scrollphathd_1.1.0_all.deb


It's a bit crude but resolves the problem. No idea why we need that package in a standard Raspbian install since it's for special hardware.
I believe that should be cd /var/cache/apt/archives
(note the "s" on the end of archives)

DavidMS
Posts: 139
Joined: Fri May 25, 2012 8:48 pm
Contact: Website

Re: [SOLVED] python-scrollphathd upgrade problem

Mon Jan 15, 2018 12:54 pm

I just did a sudo apt-get install pip - it reported the current version was latest and then carried on with the 35 files it miss the first time
http://meanderingpi.wordpress.com/
11 Raspberry Pi's and counting....

Luigi3711
Posts: 23
Joined: Sat Dec 30, 2017 3:24 pm

Re: [SOLVED] python-scrollphathd upgrade problem

Mon Jan 15, 2018 9:31 pm

I have the same problem, but nothing is working. In almost every line, it has something to do with a java plugin and armhf.

User avatar
DougieLawson
Posts: 38489
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: [SOLVED] python-scrollphathd upgrade problem

Mon Jan 15, 2018 9:36 pm

sudo dpkg -i --force-overwrite /var/cache/apt/archives/python3-scrollphathd_1.1.0_all.deb
Last edited by DougieLawson on Mon Jan 15, 2018 11:08 pm, edited 1 time in total.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

Luigi3711
Posts: 23
Joined: Sat Dec 30, 2017 3:24 pm

Re: [SOLVED] python-scrollphathd upgrade problem

Mon Jan 15, 2018 10:36 pm

When I enter the command, I get this:

[email protected]:/var/cache/apt/archives $ sudo dpkg -i --force-install /var/cache/apt/archives/python3-scrollphathd_1.1.0_all.deb
dpkg: error: unknown force/refuse option 'install'

Type dpkg --help for help about installing and deinstalling packages [*];
Use 'apt' or 'aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !

It seems that there is more than one problem.

I also found lines that said something about a java plugin and armhf.

User avatar
DougieLawson
Posts: 38489
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: [SOLVED] python-scrollphathd upgrade problem

Mon Jan 15, 2018 11:08 pm

Sorry it's --force-overwrite (should have checked my other posts).
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

Luigi3711
Posts: 23
Joined: Sat Dec 30, 2017 3:24 pm

Re: [SOLVED] python-scrollphathd upgrade problem

Mon Jan 15, 2018 11:43 pm

Nothing seems to be working.

hippy
Posts: 7127
Joined: Fri Sep 09, 2011 10:34 pm
Location: UK

Re: python-scrollphathd upgrade problem

Tue Jan 16, 2018 6:42 pm

davidcoton wrote:
Sun Jan 14, 2018 11:37 pm
Two possible reasons:
  1. Mistake :o :shock: :?
  2. Preparation for h/w built in to imminent Pi4B :twisted:
Just to round off the thread. It appears to have been a mistake / oversight -

viewtopic.php?f=116&t=202583#p1259740

And, from that, it seems the issue has been resolved and is working its way out for future updates.

Return to “Troubleshooting”