Page 1 of 1

notify-send isn't working for me

Posted: Tue Dec 12, 2017 1:16 pm
by woodscooter
I have installed notify-send on my Pi but no notifications are appearing. Can anyone suggest how I can find out why not?

The install was 'sudo apt-get install libnotify-bin' and there were no errors reported.
To test it I've tried 'notify-send "Test Message" '. Nothing happens after I press Enter.
In case it didn't know where to send the notification, I entered 'export DISPLAY=:0.0' and tried again.
I've looked in /var/log for error messages, in syslog, messages, daemon.log and lightdm/lightdm.log. Nothing logged.
I'm using Raspbian Jessie.

Any hints or help will be appreciated.

Re: notify-send isn't working for me

Posted: Tue Dec 12, 2017 2:21 pm
by pcmanbob

Re: notify-send isn't working for me

Posted: Wed Dec 13, 2017 10:18 pm
by woodscooter
Thanks for the link to raspberrypi.stackexchange. It was helpful, as I got the notification-daemon running and notify-send worked for me, for about 20 minutes.

Now I have some error messages that I don't understand, but at least it's talking to me. I'll get it figured out a step at a time.

Code: Select all

No protocol specified

** (notification-daemon:2811): WARNING **: Could not open X display
No protocol specified
Unable to init server: Could not connect: Connection refused

(notification-daemon:2811): Gtk-WARNING **: cannot open display: :0