woodscooter
Posts: 4
Joined: Wed Nov 02, 2016 8:53 pm

notify-send isn't working for me

Tue Dec 12, 2017 1:16 pm

I have installed notify-send on my Pi but no notifications are appearing. Can anyone suggest how I can find out why not?

The install was 'sudo apt-get install libnotify-bin' and there were no errors reported.
To test it I've tried 'notify-send "Test Message" '. Nothing happens after I press Enter.
In case it didn't know where to send the notification, I entered 'export DISPLAY=:0.0' and tried again.
I've looked in /var/log for error messages, in syslog, messages, daemon.log and lightdm/lightdm.log. Nothing logged.
I'm using Raspbian Jessie.

Any hints or help will be appreciated.

pcmanbob
Posts: 7255
Joined: Fri May 31, 2013 9:28 pm
Location: Mansfield UK

Re: notify-send isn't working for me

Tue Dec 12, 2017 2:21 pm

We want information… information… information........................no information no help
The use of crystal balls & mind reading are not supported

woodscooter
Posts: 4
Joined: Wed Nov 02, 2016 8:53 pm

Re: notify-send isn't working for me

Wed Dec 13, 2017 10:18 pm

Thanks for the link to raspberrypi.stackexchange. It was helpful, as I got the notification-daemon running and notify-send worked for me, for about 20 minutes.

Now I have some error messages that I don't understand, but at least it's talking to me. I'll get it figured out a step at a time.

Code: Select all

No protocol specified

** (notification-daemon:2811): WARNING **: Could not open X display
No protocol specified
Unable to init server: Could not connect: Connection refused

(notification-daemon:2811): Gtk-WARNING **: cannot open display: :0

Return to “Troubleshooting”