FUNcation
Posts: 6
Joined: Mon Dec 11, 2017 12:01 am

Pi3 HDMI to DVI Samsung SA450 syncmaster ???

Mon Dec 11, 2017 12:07 am

I'm trying to connect Pi3 via HDMI to DVI Samsung SA450 syncmaster monitor.
I got DVI-D converter but all I see is white line across the screen. I tried several HDMI2DVI cables as well - same result.
Any help appreciated. Thanks
Attachments
cablesHDMIDVI.jpg
cablesHDMIDVI.jpg (99.35 KiB) Viewed 641 times
DVIone.jpg
DVIone.jpg (96.17 KiB) Viewed 641 times
MonitorDVI.jpg
MonitorDVI.jpg (95.65 KiB) Viewed 641 times

User avatar
HawaiianPi
Posts: 5077
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Pi3 HDMI to DVI Samsung SA450 syncmaster ???

Mon Dec 11, 2017 1:18 am

That's odd. I'm using an HDMI to DVI adapter similar to the one in your second picture with my Pi3 and a Samsung SyncMaster 940BW.

My adapter looks like this:
Image

The adapter is attached to the monitor's DVI port and I have a normal HDMI cable between my Pi3 and the adapter. I used a similar setup previously with an Acer AL2032 monitor and it worked as well (different brand adapter, but basically the same layout). The Acer was 1680x1050 resolution, and the Samsung is 1440x900. On both the Pi3 just booted up at the correct resolution without any special configuration (which is more than I can say for my crappy Tinker Board).

The white line would seem to indicate its getting some kind of signal, unless the monitor itself is bad. Does that white line show with no input cable? And have you tested the monitor on any other computer to confirm it's working?

Are you using your Pi3 in a case? Sometimes a case might prevent a cable from plugging all the way into a port.

Are you using the latest Raspbian OS? If not, grab the latest Raspbian image and write it to a card with Etcher.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

FUNcation
Posts: 6
Joined: Mon Dec 11, 2017 12:01 am

Re: Pi3 HDMI to DVI Samsung SA450 syncmaster ???

Mon Dec 11, 2017 9:31 pm

HawaiianPi wrote:
Mon Dec 11, 2017 1:18 am

Are you using your Pi3 in a case? Sometimes a case might prevent a cable from plugging all the way into a port.
Yes everything fits, cable is plugged all the way

Are you using the latest Raspbian OS? If not, grab the latest Raspbian image and write it to a card with Etcher.

I think I recently did "sudo apt-get update" & upgrade
is that enough?
I tried on 2 different monitors. On one it showed main screen for a sec and than went to white horizontal line. On HDMI monitor and HDTV works great.

FUNcation
Posts: 6
Joined: Mon Dec 11, 2017 12:01 am

Re: Pi3 HDMI to DVI Samsung SA450 syncmaster ???

Tue Dec 12, 2017 5:47 pm

at boot time I now see the text and 3 berries but as soon as it gets into GUI mode same white line across. I tried to change resolution to something like 1200x720 but no luck.

Return to “Troubleshooting”