shadowban
Posts: 2
Joined: Tue Nov 21, 2017 11:41 am

Ubuntu Xenial 16.04.3 can not upgrade

Tue Nov 21, 2017 11:45 am

Hi guys,
I'm new to this forum. I can not upgrade my ubuntu Xenial 16.04 running on my raspberry pi 3. I have run the following commands:

Code: Select all

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
The following results are what I got. This problem is haunting me a couple of days. Please help if you know! Thanks a lot!
Do you want to continue? [Y/n] Y
Setting up python3.5-minimal (3.5.2-2ubuntu0~16.04.3) ...
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes
Sorry: ValueError: source code string cannot contain null bytes

dpkg: error processing package python3.5-minimal (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python3.5:
python3.5 depends on python3.5-minimal (= 3.5.2-2ubuntu0~16.04.3); however:
Package python3.5-minimal is not configured yet.

dpkg: error processing package python3.5 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of idle-python3.5:
idle-python3.5 depends on python3.5; however:
Package python3.5 is not configured yet.

dpkg: error processing package idle-python3.5 (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3.5-dev:
python3.5-dev depends on python3.5 (= 3.5.2-2ubuntu0~16.04.3); however:
Package python3.5 is not configured yet.

dpkg: error processing package python3.5-dev (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
python3.5-minimal
python3.5
idle-python3.5
python3.5-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)
Last edited by shadowban on Tue Nov 21, 2017 12:34 pm, edited 1 time in total.

shadowban
Posts: 2
Joined: Tue Nov 21, 2017 11:41 am

Re: Ubuntu Xenial 16.04.3 can not upgrade

Tue Nov 21, 2017 12:33 pm

It's driving me crazy...

User avatar
fruitoftheloom
Posts: 15047
Joined: Tue Mar 25, 2014 12:40 pm
Location: Bognor Regis UK

Re: Ubuntu Xenial 16.04.3 can not upgrade

Tue Nov 21, 2017 12:47 pm

shadowban wrote:
Tue Nov 21, 2017 12:33 pm
It's driving me crazy...

Have you contacted the Developers of that Distribution ??

Maybe the Ubuntu-Mate Forum would have Raspberry Pi Users ??

https://ubuntu-mate.community/c/support/raspberry-pi-2
My only "PC" is an Asus ChromeBit running ChromeOS, cloudcentric at its best !
Rockchip Quad-Core RK3288C SoC as used in ASUS Chromebook C201 & Chromebook Flip C100PA as well as the Tinker SBC.
3 Mobile Huawei E5330 Mobile Mi-Fi

fanoush
Posts: 258
Joined: Mon Feb 27, 2012 2:37 pm

Re: Ubuntu Xenial 16.04.3 can not upgrade

Tue Nov 21, 2017 6:04 pm

shadowban wrote:
Tue Nov 21, 2017 11:45 am

Code: Select all

apt-get upgrade
Maybe this is the reason, try 'apt-get dist-upgrade'. In most cases plain upgrade is not what you want.

Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 46 guests