Page 1 of 1

Bluetooth Audio

Posted: Mon Oct 30, 2017 4:25 pm
by akashr04
Hi everyone! I am using RPi 3 with Raspbian Stretch. I have been having issues playing audio over my bluetooth speaker. I am able to pair and connect to my bluetooth speaker, and I see it in the list of connected devices. But even after changing the default sink to this bluetooth speaker, I don't hear any sound.
The following bulleted points explain what's going on
1. Pairing is successful (bluetoothctl)
2. Connection is successful (bluetoothctl)
3. When trying to stream audio:
a. Using VLC: the tone is apparently played and I see the progress bar at the bottom of the VLC GUI reach completion, but I don't hear anything.
B. Using play command ( from sox : sudo apt-get install sox), the terminal appears to freeze, and no audio is streamed. The completion bar continues to remain at 0%. Again, obviously, I dont hear any sound.

I have tried a bunch of solutions: modifying audio.conf file, hiding the ALSA audio control bar, and quite a few others. I've been at this for over a week now. Please help me out..

Re: Bluetooth Audio

Posted: Mon Oct 30, 2017 4:40 pm
by jamesh
Been a lot of very recent updates to the BT system (today!)- please ensure you system is right up to date and test again.

Re: Bluetooth Audio

Posted: Mon Oct 30, 2017 7:29 pm
by akashr04
Hello Jamesh. After running an update on my pi, I am now facing a different issue. Like before, I can pair and connect to my bluetooth speaker but this time around, the speaker is not even listed as an audio sink. When I enter "pacmd list-sinks", I do not anymore see the device. using vlc, I couldn't find the speaker in the list of audio devices either.

Re: Bluetooth Audio

Posted: Tue Oct 31, 2017 11:47 am
by ShiftPlusOne
Could you try running 'sudo systemctl stop bluealsa && sudo systemctl disable bluealsa" then rebooting?

Re: Bluetooth Audio

Posted: Tue Oct 31, 2017 2:53 pm
by akashr04
I tried those commands. I got a prompt saying "alsa service removed". After this, I tried connecting and pairing to my speaker. As before I was successful but I couldn't find it in the list of audio sinks. So, I still haven't been able to stream any audio. I tried VLC as well.

Re: Bluetooth Audio

Posted: Tue Oct 31, 2017 3:27 pm
by ShiftPlusOne
akashr04 wrote:
Tue Oct 31, 2017 2:53 pm
I tried those commands. I got a prompt saying "alsa service removed". After this, I tried connecting and pairing to my speaker. As before I was successful but I couldn't find it in the list of audio sinks. So, I still haven't been able to stream any audio. I tried VLC as well.
Neither of the commands I gave would give you that output.

Re: Bluetooth Audio

Posted: Tue Oct 31, 2017 4:43 pm
by akashr04
Okay so I re-ran the commands and performed a cold boot-up. Now I can successfully pair, connect and stream audio.

Thanks a lot for your help!

Re: Bluetooth Audio

Posted: Mon Feb 19, 2018 7:49 pm
by wojciechk2
akashr04 what did you mean by "I re-ran the commands and performed a cold boot-up". What did the commands were? I have the same problem. Share it please.

Re: Bluetooth Audio

Posted: Tue Feb 20, 2018 2:24 pm
by akashr04
Could you try running 'sudo systemctl stop bluealsa && sudo systemctl disable bluealsa" then rebooting?
Those are the commands I ran to be able to connect and play audio. Make sure to reboot after entering those commands.

If you need more help, just let me know in this thread.
Good luck.