Crunkrock
Posts: 7
Joined: Sat Aug 19, 2017 9:22 pm

Pixel desktop stays black

Sat Aug 26, 2017 1:01 pm

While I was trying to fix viewtopic.php?p=1203006 I first thought it might be an X11 problem, which is why I reinstalled xserver. As you see in viewtopic.php?p=1203006 the Kodi problem was fixed with a different solution, however, since then, my xserver doesn't work right anymore. Quoting myself from the other topic where I initially posted this:
Crunkrock wrote:
Sat Aug 26, 2017 9:34 am
Well, great, now I have a different problem. I updated kodi, and kodi-standalone is working, yay! First of all, thanks for all the help regarding that.

However, when I do

Code: Select all

startx
the screen stays just black. When I access it via VNC I see the PIXEL desktop without problems.

I tried to purge and reinstall

Code: Select all

xserver-xorg-core
as well as

Code: Select all

raspberry-ui-mods
. I tried to

Code: Select all

export DISPLAY=:0
and then

Code: Select all

xhost +
, only to see

Code: Select all

xhost: unable to open display ":0"
I think this might not even be related to updating kodi. I reinstalled xserver back when I thought it was related to kodi not starting up. Maybe I destroyed anything there?

fruitoftheloom
Posts: 24052
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Pixel desktop stays black

Sat Aug 26, 2017 5:36 pm

Crunkrock wrote:
Sat Aug 26, 2017 1:01 pm
While I was trying to fix viewtopic.php?p=1203006 I first thought it might be an X11 problem, which is why I reinstalled xserver. As you see in viewtopic.php?p=1203006 the Kodi problem was fixed with a different solution, however, since then, my xserver doesn't work right anymore. Quoting myself from the other topic where I initially posted this:
Crunkrock wrote:
Sat Aug 26, 2017 9:34 am
Well, great, now I have a different problem. I updated kodi, and kodi-standalone is working, yay! First of all, thanks for all the help regarding that.

However, when I do

Code: Select all

startx
the screen stays just black. When I access it via VNC I see the PIXEL desktop without problems.

I tried to purge and reinstall

Code: Select all

xserver-xorg-core
as well as

Code: Select all

raspberry-ui-mods  
. I tried to

Code: Select all

export DISPLAY=:0
and then

Code: Select all

xhost +
, only to see

Code: Select all

xhost: unable to open display ":0"
I think this might not even be related to updating kodi. I reinstalled xserver back when I thought it was related to kodi not starting up. Maybe I destroyed anything there?
FYI Pixel Desktop was retired, it is now Raspberry Pi Desktop when you use raspberry-ui-mods excetera
Thinking outside the box is better than burying your head in the sand...

Crunkrock
Posts: 7
Joined: Sat Aug 19, 2017 9:22 pm

Re: Pixel desktop stays black

Sat Aug 26, 2017 9:29 pm

Oh, OK. Yeah. Problem stays the same though :)

Return to “Troubleshooting”