User avatar
mainframe
Posts: 7
Joined: Mon Jul 17, 2017 2:03 am

How can I configure sshd to automatically start?

Mon Jul 17, 2017 2:12 am

This is what I get when I've tried what others said to do:

Code: Select all

root@raspberrypi:/home/pi # systemctl enable sshd.service
Failed to execute operation: No such file or directory

root@raspberrypi:/home/pi # update-rc.d ssh defaults
insserv: warning: current start runlevel(s) (empty) of script `ssh' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (2 3 4 5) of script `ssh' overrides LSB defaults (empty).
I have the Rasp Pi Zero W.

daveyman123
Posts: 119
Joined: Fri Dec 12, 2014 2:21 am

Re: How can I configure sshd to automatically start?

Mon Jul 17, 2017 3:50 am

You are trying to start ssh?

User avatar
mainframe
Posts: 7
Joined: Mon Jul 17, 2017 2:03 am

Re: How can I configure sshd to automatically start?

Mon Jul 17, 2017 4:07 am

daveyman123 wrote:You are trying to start ssh?
No, I'm trying to configure the system so that the system itself starts sshd when it boots up.

DirkS
Posts: 10516
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: How can I configure sshd to automatically start?

Mon Jul 17, 2017 6:19 am

Try 'ssh.service' (without the d).

sparkyhall
Posts: 168
Joined: Mon Aug 27, 2012 9:14 am

Re: How can I configure sshd to automatically start?

Mon Jul 17, 2017 7:34 am

Why not enable sshd using 'sudo raspi-config' like you are supposed too?

User avatar
jahboater
Posts: 6533
Joined: Wed Feb 04, 2015 6:38 pm
Location: Wonderful West Dorset

Re: How can I configure sshd to automatically start?

Mon Jul 17, 2017 8:00 am

Or put an empty file called "ssh" in the /boot partition.

Return to “Troubleshooting”