Posts: 102
Joined: Tue Oct 28, 2014 6:44 am


Mon May 15, 2017 2:24 am

For a couple of years now I've had great success with Bill Wilson's for dupicating SD cards on the pi. Great little utility that automatically resizes to fit the card your duplicating to. When I moved to jessie lite last year it still worked great.

However last night with a slightly different jessie lite version it fell over. By that I mean it duplicates the card in the pi slot OK, no error messages, but the duplicated card won't boot, crashes out with "kennel panic - not syncing: VFS: unable to mount root fs on unknown-block (179,7)". This message is double dutch to an old microcontroller bit banger like me so I'm hoping one of the cognoscenti on this forum can offer some kind words of wisdom? The duplicated cards appear to have identical files on them to the original although a Windows PC shows them as to be nowhere as 'full' as the original

Posts: 246
Joined: Fri Jun 10, 2016 3:18 pm

Re: Rpi-clone

Mon May 15, 2017 7:51 am

Hi there,

I fastly read the script, and it doesn't seemed to be raspbian related at all.
So problem shouldn't come from that, did you try again and had the same trouble?
Did you "sudo" ?


Posts: 1346
Joined: Thu Oct 09, 2014 2:50 am

Re: Rpi-clone

Wed May 17, 2017 4:51 am

Have you tried piclone (or SD Card Copier from the Accessories menu in Pixel)?

Posts: 49
Joined: Wed Jul 10, 2013 6:22 am

Re: Rpi-clone

Wed May 17, 2017 6:51 am

The obvious thing would be that your new SD card is bad. Try another card. I have never used one of these utilities. It is pretty easy to do manually. Compare the sizes of the 2 SD cards(not just the *GB label, but what you get from fdisk -l.. If the new card is bigger, just dd the old one to the new one using another Linux system. If the new one is smaller, I shrink the old filesystem a bit with gparted, back it up to a file on the Linux box with dd, and then write the new card. The toughest part is computing the size of the backup of the old card. The end result is a nice backup as well as a duplicated Pi setup.
Good luck

Return to “Troubleshooting”