rbarrett
Posts: 5
Joined: Thu Jun 09, 2016 11:07 pm

Trying to use ssh

Wed May 03, 2017 6:06 am

Hello Colleagues

I have a Macbook air and a Rp3. I am trying to remotely connect my mac to the RP3 with ssh. I keep on having problems which I will detail in the hope that one or more of you can help.

I have successfully got my internet address of my RP3. 192.168.1.11

Using my Mac terminal I typed in ssh 192.168.1.11 -2 pi

I had already tried ssh 192.168.1.11 -1 pi but was informed Protocol major versions differ:1 vs 2

I was asked for the password and assumed it was raspberry

I was informed permission was denied and asked to try again.

I subsequently tried both my apple password and my internet password but failed each time.

Does anyone know the correct password or how I can find it?

I have to write an article about this so I am really stuck. Please help!

Rory Barrett

jahboater
Posts: 5926
Joined: Wed Feb 04, 2015 6:38 pm
Location: West Dorset

Re: Trying to use ssh

Wed May 03, 2017 7:25 am

I use:

ssh pi@192.168.1.11

You must have enabled ssh on the Pi first by placing a file called "ssh" in the boot FAT partition.

The default password for user pi is raspberry, you should change that.

Return to “Troubleshooting”