User avatar
elkberry
Posts: 167
Joined: Wed Dec 28, 2016 9:21 pm

Pi Zero W as unintended 5GHz jammer?

Thu Mar 30, 2017 7:28 pm

Now this is strange: I have a Raspberry Pi Zero W connected to WLAN access points, Fritz!Boxes in my case. While the Pi Zero W is switched on, my Microsoft Surface Pro 3 tablet reproducable cannot successfully communicate in the 5GHz band with these access points anymore. The SF3 shows full WLAN strenght, but most data frames go to the Ether...

I need to switch the SF3 over to 2.4GHz where it can talk to my access point without any problems. Luckily, other 5GHz devices, such as a Samsung Galaxy Tab S successfully communicate in the 5Ghz band.

Had anyone experienced similar problems with other devices when their Pi Zero Ws are switched on?
Last edited by elkberry on Thu Mar 30, 2017 8:22 pm, edited 1 time in total.
From ZX81 to Raspberry Pi, but wait ... where's the 7805 gone?

gregeric
Posts: 1509
Joined: Mon Nov 28, 2011 10:08 am

Re: Pi Zero W as unintended 5GHz jammer?

Thu Mar 30, 2017 7:57 pm

No such goings on here - I have ZeroW's connected to a 2.4GHz hotspot in the vicinity of a 5GHz hotspot & connected devices. There again, I don't have an MS Surface Pro, only Motorola Moto-X to test with.

Surely any such "jamming" issues would have been picked up in the FCC testing?

User avatar
elkberry
Posts: 167
Joined: Wed Dec 28, 2016 9:21 pm

Re: Pi Zero W as unintended 5GHz jammer?

Thu Mar 30, 2017 8:57 pm

Maybe someone want to try a Pi Zero W next to an Apple/LG 4K monitor...? 8-)

But as I'm writing this it only now occurs to me that's maybe something the FCC tests don't cover, as it may be caused by I2C interference from a Scroll pHAT HD. I've now stopped the script that outputs nice stuff to the pHAT, and I notice that the SF3 now uses 5GHz WLAN without any problems. And I remember that today while in the lab the WLAN outages of the SF3 were gone whenever I stopped the script while working on changes or debugging.

So the title may be better rephrased as "How To Jam a Surface Pro 3 using the Scroll pHAT HD"... :?
From ZX81 to Raspberry Pi, but wait ... where's the 7805 gone?

Return to “Troubleshooting”