Page 1 of 1

[SOLVED] Pi0W: gadget mode: dwc2_hsotg_enqueue_setup: faile

Posted: Wed Mar 22, 2017 9:12 pm
by elkberry
I'm using the recent Raspbian image with support for the Raspberry Pi Zero W. It has wifi set up and connects to my home wireless LAN. So far, so good.

Next, I wanted to add USB ethernet gadget support. So I followed these instructions given here: https://gist.github.com/gbaman/975e2db1 ... e45e8fd40a ... the overlay gets activated, the drivers loaded.

After the Pi 0 W has booted, I see that it has loaded the g_ether from the list of loaded kernel modules. Unfortunately, neither my Linux system nor my Windows box recognizes the Pi0W when connecting it to these boxes using a normal A-microB cable. dmesg turns up with ugly thing here:

Code: Select all

dwc2 20980000.usb: dwc2_hsotg_enqueue_setup: failed queue (-11)
I've searched the forum and googled around, but didn't find anything that helps me getting my Pi0W working as intended. Any help greatly appreciated -- I might have not searched correctly.

Re: Pi0W: gadget mode: Ethernet: dwc2_hsotg_enqueue_setup: f

Posted: Wed Mar 22, 2017 9:34 pm
by elkberry
I've checked with a second Pi0W luckily I could get my hands on ... and guess: the other Pi0W works as advertised. Looks as if there are faulty batches in the pipeline. Grrr.

UPDATE: looks like there is now a driver fix (whatever), because previously non-working RPi0W's start to work for me. See below.

Re: [SOLVED] Pi0W: gadget mode: dwc2_hsotg_enqueue_setup: fa

Posted: Thu Mar 23, 2017 4:03 am
by baseman101
I have the same problem - I guess I'll have to take a trip to Microcenter and get a new one :/.

Re: [SOLVED] Pi0W: gadget mode: dwc2_hsotg_enqueue_setup: fa

Posted: Fri Mar 31, 2017 11:07 am
by grmpyninja
Is it actually an official solution to this problem? Are you sure it's not because of some issues with the kernel?

I got the same issue in logs, but a single USB gadget always works. Checked HID, Mass Storage, Ethernet. However, when I try to configure two (or more) gadgets at the same time, it looks like only the first one is recognized.

Also I'm using libcomposition instead of older g_ether/g_hid and so on.

Re: [SOLVED] Pi0W: gadget mode: dwc2_hsotg_enqueue_setup: fa

Posted: Fri Mar 31, 2017 4:30 pm
by elkberry
No, if you read my post then you will notice that I tried the same physical mSD in two Pi Zero Ws. No, it's not a kernel issue at this time, there's no patch available. And no, I never wrote about a single USB ethernet adaptor attached using a OTG cable, but I mentioned USB Ether gadget mode. But then, everything boils down to what I wrote in the beginning.

A free replacement Pi Zero W is already on its way to me.

Re: [SOLVED] Pi0W: gadget mode: dwc2_hsotg_enqueue_setup: fa

Posted: Tue Apr 04, 2017 4:33 pm
by elkberry
Got my replacement RPi0W, which unfortunately is broken too: USB gadget mode does not work either! Cross-checked the same mSD in the working RPi0W: there, it works correctly. I've only now noticed that the good one also shows the error message in dmesg, so the presence of this error doesn't seem to be a clear indication. Good one works, can be ping'ed. Bad ones cannot be ping'ed and cannot ping.

Re: [SOLVED] Pi0W: gadget mode: dwc2_hsotg_enqueue_setup: fa

Posted: Tue Apr 04, 2017 5:42 pm
by elkberry
Recent raspbian update now fixes the RPi0W's that previously failed to work correctly in USB Ethernet gadget mode. With these updates I can now successfully ping and ssh into the problematic RPi0W by connecting it with a microB<->A cable to my Linux and Windows boxes.

So I stand corrected that it is now clear that this is a driver issue, and not a hardware issue (albeit you may still get a faulty unit, but this ain't a widespread issue).