Mantrid
Posts: 33
Joined: Thu Jun 21, 2012 8:44 am
Location: Middlesbrough/Armagh

Newest update breaks webcam?

Sun Sep 16, 2012 12:29 pm

Hi all

I've been able to stream and cap video from a webcam for a few months now. When I switched to Raspbian things were ok, a few niggles with cameras but I was getting through them, After updating with rpi-update though things seems to have hit a new wall in that /dev/video0 doesn't exist anymore

DMESG:

Code: Select all

.802692] videodev: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[    8.170998] snd: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[   13.493967] EXT4-fs (sda2): re-mounted. Opts: (null)
[   14.098195] snd: version magic '3.2.27+ preempt mod_unload modversions ARMv6 ' should be '3.2.27+ preempt mod_unload modversions ARMv6 p2v8 '
[   25.931511] smsc95xx 1-1.1:1.0: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
But lsusb sees it and the model of camera has worked fine ever since I got it with no manual intervention needed:

Code: Select all

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. 
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 004: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) 64MB QDI U2 DISK
Bus 001 Device 005: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 006: ID 0471:20bb Philips (or NXP) 
Bus 001 Device 007: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Is there a known issue (And even handier a known easy workaround ;) or is it just me that this affects at the moment?

Mantrid
Posts: 33
Joined: Thu Jun 21, 2012 8:44 am
Location: Middlesbrough/Armagh

Re: Newest update breaks webcam?

Sun Sep 16, 2012 4:04 pm

Not sure but googling around for the preempt thing seems to suggest the drivers for the cam were compiled for a previous kernel or some such?

I'm assuming this means I have to find the source for the philips webcam drivers and recompile them against the kernel I'm running at the moment..

Not sure if that's right, but either way i can't find out how to do that if someone's able to point me somewhere?

cheers!

Mantrid
Posts: 33
Joined: Thu Jun 21, 2012 8:44 am
Location: Middlesbrough/Armagh

Re: Newest update breaks webcam?

Mon Sep 17, 2012 7:38 pm

Hi again (keeping thread updated in case it becomes someone's google result..)

Tried looking for Driver source files (philips or NXP SPZ5000) but can't seem to find any anywhere

Is it normal for drivers to stop working between versions? that makes upgrading a bit more dangerous than I thought

Or if anyone know of any source files that'd be a help too

Mantrid
Posts: 33
Joined: Thu Jun 21, 2012 8:44 am
Location: Middlesbrough/Armagh

Re: Newest update breaks webcam?

Tue Oct 30, 2012 10:20 pm

When I run

Code: Select all

find / -name videodev*ko
I get the following results, could one of these be an older one that's still being used after an upgrade or are both of these right in being there?

Code: Select all

/lib/modules/3.2.27-cutdown+/kernel/drivers/media/video/videodev.ko
/lib/modules/3.2.27+/kernel/drivers/media/video/videodev.ko
cheers anyone :(

kubaraczkowski
Posts: 2
Joined: Sat Aug 04, 2012 10:38 am

Re: Newest update breaks webcam?

Sat Dec 01, 2012 7:58 pm

Any update on this? My webcam does not work, though I did not try it before... But the messages on dmesg are the same! :)

Rgrds,

Mantrid
Posts: 33
Joined: Thu Jun 21, 2012 8:44 am
Location: Middlesbrough/Armagh

Re: Newest update breaks webcam?

Sat Dec 01, 2012 8:18 pm

Hi. i got the latest os instead of upgrading the pre-hard float one. There was a command to search for drivers in another thread ans it showed two drivers. the upgrqde had the newer ine but the older one was being used.

For me DLing newer os image ans reflashing the car new fixed it.

apologies about the text but im on my phone and a bit drunk but hope it helps!

Mantrid
Posts: 33
Joined: Thu Jun 21, 2012 8:44 am
Location: Middlesbrough/Armagh

Re: Newest update breaks webcam?

Sat Dec 01, 2012 8:29 pm

Juat noticed that command ia in my previous post, try it. im highly unsociable at this houseparty!

Return to “Troubleshooting”