pjft
Posts: 3
Joined: Fri Jan 20, 2017 11:02 pm

Acestream on Kodi 17 fails a lot

Wed Feb 15, 2017 4:34 pm

Hi all,

Apologies for the trouble, just wanted to give more of a FYI but also potentially ask if anyone is experiencing this and what workarounds people have. In particular I know Rascas was involved in porting this, and may have some thoughts - or at least would like to be made aware of the context here.

Summarizing: I've been on Raspbian Jessie, running Kodi 16.1.x for the last 6 months, and running Acestream using the proposed Plexus + delete + Android chroot solution in the famous PasteBin instructions. Everything ran smoothly as expected all the time - sometimes it can't find a stream and it fails, but other than that all good.

I decided to upgrade Kodi last week, to 17.x, and suddenly the Acestream performance is much more hit and miss. Sometimes it will load correctly, but more often than not it will either just load a black screen that states that the stream has ended, or in the odd occasion it will load the stream but just play the audio, with no video. Sometimes even for the same stream, but other times some streams will just plain not work - I had very low success with the ones from ArenaVision, for some reason, whereas on Kodi 16 they do work. Sometimes (very rarely) if I rewind the stream a tiny bit it will display the video, but very rarely. I can say my success rate with Acestream in Kodi 17 was around 30%.

I found online an Android zip for Raspberry Pi with a more up to date version (3.1.6, I believe) but the results are exactly the same. The thing is, when I run it in Kodi 16, it all works well - I have two microSD cards, so I restored a previous backup to it and tested both for the same sets of streams kind of at the same time, in case it was a stream's fault.

My main problem is that, inspecting the acestream logs, I can't figure out any meaningful difference between:
- Stream running in 16;
- Stream running in 17;
- Stream failing in 17;

So I'm kind of at a loss.

For the time being, I downgraded to Kodi 16, and it all works well as expected (I did not restore an image, but I downgraded the kodi and kodi-bin packages). I also set an apt-mark hold on kodi and kodi-bin, just in case.

Still, if anyone else has experienced this/is experiencing this, or has any further ideas, I'd love to hear them or help in any way I can. I'm also happy to share the logs, though I don't know if they'd help in any way shape or form. I don't know how long Kodi 16 will be around for, and/or for how long it will be compatible with the current Raspbian releases...

Let me know if there's any more information I can help with.

Thanks, and have a great day.

Rascas
Posts: 333
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Acestream on Kodi 17 fails a lot

Sun Feb 19, 2017 6:26 pm

I didn't find any diferences with acestreams on Kodi 17, it runs the same as previous versions. Did you tested with clean Kodi settings, moving ~/.kodi ? And make sure there isn't much things running in the background, check with top, for example.

pjft
Posts: 3
Joined: Fri Jan 20, 2017 11:02 pm

Re: Acestream on Kodi 17 fails a lot

Mon Feb 20, 2017 12:42 pm

Hi Rascas,

Good to have your perspective in that you didn't find any changes between 16 and 17 when playing acestreams.

I haven't tested it out with a clean install, I may certainly try that and see how it goes. My 16 setup is working fine for now - I may back it up later in the week and then force an upgrade and see how it goes.

Thanks, have a great day.

jazzblue
Posts: 1
Joined: Mon Mar 27, 2017 12:05 am

Re: Acestream on Kodi 17 fails a lot

Mon Mar 27, 2017 12:13 am

Almost exactly the same problem as what pjft described. Plexus/acestream was working flawlessly on Kodi 16 (OSMC). Now all the live steams stopped working after an update to Krypton- either no response at all or black screen with audio only. Hopefully someone will be able to help figure out the problem so we don't have to downgrade back to 16...

Rascas
Posts: 333
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: Acestream on Kodi 17 fails a lot

Mon Mar 27, 2017 1:52 am

jazzblue wrote:Almost exactly the same problem as what pjft described. Plexus/acestream was working flawlessly on Kodi 16 (OSMC). Now all the live steams stopped working after an update to Krypton- either no response at all or black screen with audio only. Hopefully someone will be able to help figure out the problem so we don't have to downgrade back to 16...
Make sure you have mmal enabled and omxplayer disabled in video settings.

harsha11
Posts: 2
Joined: Wed Jan 03, 2018 4:12 pm

Re: Acestream on Kodi 17 fails a lot

Wed Jan 03, 2018 4:13 pm

here the installing guide for Install Plexus Addon on Kodi Krypton 17.6 and more http://www.amdreward.com/how-to-install ... odi-addon/

Return to “Troubleshooting”

Who is online

Users browsing this forum: dcristut, otalado and 59 guests