Page 1 of 1

Not Getting Login Prompt, Putty/SSH

Posted: Wed Feb 15, 2017 4:50 am
by NoBodyUKnow
Hello All,

I'm trying to access and configure a Pi 3 or the first time, headless. I've loaded the Raspbian "Jessie" image on a 32 GB SD card using Win32 Image, inserted that into my Pi, powered it up and Ethernet cabled it to my router.

I get solid red power light and a blinky green light next to that, as well as solid yellow and blinky green lights at the Pi's LAN port.

Although it appears my router is assigning a dynamic IP, I've been able to find the Pi's IP addy. I used Advanced IP Scanner first, but didn't see anything listed at being from "Raspberry Pi Foundation". Therefore, I looked in my router config and found the IP address with the manufacturer info listed, noting that the IP addy I saw there for "raspberrypi" was, in fact listed in the scanner, but w/o ownership.

I tried accessing my Pi using Putty in SSH mode, but the request times out. I never get the login prompt or the warning from Putty about an unknown connection.

I've been using this thread for help: viewtopic.php?t=116724&p=795133

Ultimately, I want to use my Pi as an OpenVPN Server with ExpressVPN.

Any assistance, greatly appreciated!

NBUK

Re: Not Getting Login Prompt, Putty/SSH

Posted: Wed Feb 15, 2017 5:09 am
by fruitoftheloom
SSH is disabled by default in Raspbian Jessie since November release:

https://www.raspberrypi.org/blog/archive

https://www.raspberrypi.org/documentation/remote-access

Re: Not Getting Login Prompt, Putty/SSH

Posted: Wed Feb 15, 2017 2:23 pm
by NoBodyUKnow
Thanks for the info, F' Loom.

Is there any way to gain headless access to my Pi, to enable SSH? It appears the other methods (VCN and Web Access) also require prior access to the Pi to enable the functionality. I do not currently have access to an HDMI monitor

Re: Not Getting Login Prompt, Putty/SSH

Posted: Wed Feb 15, 2017 2:39 pm
by jahboater
NoBodyUKnow wrote:Is there any way to gain headless access to my Pi, to enable SSH? It appears the other methods (VCN and Web Access) also require prior access to the Pi to enable the functionality. I do not currently have access to an HDMI monitor
Yes, its simple. Just create a file called "ssh" in the small FAT boot partition (that you can see from Windows). Replace the SD card in the Pi and it will enable ssh for you, and delete the ssh file.

The file can be empty and echo "" >ssh should be enough.

Re: Not Getting Login Prompt, Putty/SSH

Posted: Wed Feb 15, 2017 8:20 pm
by gauravj
Hi,
I am trying the above instructions but still i am not able to login into SSH. I have create an empty file "ssh" in the root of SD card

I am using Mac Terminal, RaspberryPi3-B and NOOBS:2.1.0 and I have pi's IP from router. It is throwing below error

Code: Select all

$ ssh [email protected]
ssh: connect to host 192.168.0.4 port 22: Connection refused
Thanks

Re: Not Getting Login Prompt, Putty/SSH

Posted: Wed Feb 15, 2017 9:01 pm
by NoBodyUKnow
Thanks!

I used the following guidance, from this thread: viewtopic.php?f=91&t=168642

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
by Martin Frezman ยป Sun Dec 18, 2016 5:00 pm
Here's the simple answer.

On windows, insert the card into whatever slot you are using (either something on the main system or in a USB slot). Figure out, using whatever tools you are comfortable with, what drive letter the SD card is (will usually be something like F:) Below, I will assume it is F:.

Press Windows Key and r at the same time. At the "Run" prompt, enter "cmd" (without the quotes) and hit enter.

At the C> prompt (or whatever it is), type "dir F:" and hit enter.
You will see a bunch of files.
At the C> prompt, type: "echo.>F:\ssh" and hit enter.

Now do whatever it takes to "safely remove" the SD card from the Windows machine.

Take the card and boot it on the Pi.
Trust me; I know what I'm doing. If you don't understand a post of mine (and I do frequently write cryptically), you may want to read more closely rather than assume it makes no sense.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~`

I'm now in touch with my Pi.

Re: Not Getting Login Prompt, Putty/SSH

Posted: Thu Feb 16, 2017 12:57 am
by klricks
gauravj wrote:Hi,
I am trying the above instructions but still i am not able to login into SSH. I have create an empty file "ssh" in the root of SD card

I am using Mac Terminal, RaspberryPi3-B and NOOBS:2.1.0 and I have pi's IP from router. It is throwing below error

Code: Select all

$ ssh [email protected]
ssh: connect to host 192.168.0.4 port 22: Connection refused
Thanks
Your problem is not the same. The OP is NOT using the NOOBS installer. If using NOOBs then you need to boot the NOOBS card in the RPi and then select and install the Raspbian OS. There is no OS to ssh into if you haven't done that. I think there is a way to make NOOBs install the OS 'silently' but it is much easier to use an attached keyboard/ mouse and monitor.
-OR-
Do as the OP did and install the standalone or direct Raspbian image (not NOOBS). Then enable the ssh by making the ssh file as described above.

Re: Not Getting Login Prompt, Putty/SSH

Posted: Wed Oct 04, 2017 8:57 am
by foxint
Hi Guys

Sorry to ask....but this seems the most appropriate. I am not getting the login prompt either. It was working a year ago. Today I decided it was time to update the os....but I could not get putty to work. I am using windows 10 and I am very inexperienced with unix, feeling more comfortable in the windows environment. Also on my list of DCHP on the modeum the pi has disappeared. I did pin the address that I thought it was and it was 4 in and 4 back.

Anyone have any suggestions. I did read the whole thread, but I was out of my depth.

I also tried Tight VNC to connect I can do it with windows machines....Any suggestions...???

It will be almost 2 days on theis problem...so hope to get some resolution. Perhaps I need to put the pi way for another year....

Re: Not Getting Login Prompt, Putty/SSH

Posted: Wed Oct 04, 2017 9:17 am
by RaTTuS
in this very [old] thread viewtopic.php?f=28&t=174534#p1114576

Re: Not Getting Login Prompt, Putty/SSH

Posted: Wed Oct 04, 2017 8:33 pm
by foxint
Hi Mate

Thank you. The link did not take me anywhere.

Still have the problem???? :cry: