aleifuu
Posts: 18
Joined: Sat Sep 17, 2016 9:50 am

OSError: Cannot detect RPi-Sense FB device

Tue Jan 31, 2017 4:34 am

Hi all,

I run into problem that one day one of my unit pi3 running on jessie shows this error "OSError: Cannot detect RPi-Sense FB device"

Code: Select all

Traceback (most recent call last):
  File "humidity2.py", line 8, in <module>
    sense = SenseHat()
  File "/usr/lib/python2.7/dist-packages/sense_hat/sense_hat.py", line 39, in __init__
    raise OSError('Cannot detect %s device' % self.SENSE_HAT_FB_NAME)
OSError: Cannot detect RPi-Sense FB device
Yes, I am using pi3 with senseHat. I at least have 3 units of pi3 that has senseHat attached to it. I use it to monitor humidity level in different rooms. Only one that shows this error message, other two units are working fine

There was no error before and It was working up to today when I run my code that use sense() module just spat out the error message above

Other thing that I notice is that usually when the board is powered up for the first time, the LED on senseHat would turn bright for several seconds. This time around it's just like one flashing and that's it ... could it be the senseHat unit is broken beyond-repair kind ? somehow ...

Thanks guys

noki-boy
Posts: 1
Joined: Tue Feb 14, 2017 11:14 am

Re: OSError: Cannot detect RPi-Sense FB device

Tue Feb 14, 2017 11:57 am

hi,
i got "almost" the same issue...
when i run a test,
RTIMULibDrive11
, everything looks OK and the sensehat works
the test answer every data like it is supposed to do
when i try to run a python program it didn't work and said
OSError: Cannot detect RPi-Sense FB device
also i read a lot of posts and got the right answer:
modify and add in /boot/config.txt
dtoverlay=rpi-sense
then rebbot
the rainbow on the sense disappears and i can run my program

michaelmis
Posts: 1
Joined: Fri May 04, 2018 12:50 pm

Re: OSError: Cannot detect RPi-Sense FB device

Fri May 04, 2018 2:24 pm

modify and add in /boot/config.txt
dtoverlay=rpi-sense
then rebbot

Worked for me. Thank you so much.

I had a new pi3 B+ and sensehat connected on a breadboard........ Kept thinking it was my bad connections.
https://pinout.xyz/pinout/sense_hat

Return to “Troubleshooting”

Who is online

Users browsing this forum: gigapouch and 22 guests