Page 1 of 1

Pi 3- No sound

Posted: Sat Dec 31, 2016 5:16 pm
by lordfundarbyrd
I apologize for being a noob. There is probably a simple fix to this that I'm missing. I'm also terrible at explaining things as well, so if you need something clarified let me know.

Anyways- title's pretty self-explanatory. I don't have any sound through a Bluetooth speaker, headphones, or through HDMI. I spent hours yesterday trying to get it to work to no avail.

First, I was trying to get my Bluetooth speaker to work. When I go to pair it, the option's grayed out, and it says go into the audio menu to pair it. I go into the audio menu but I only have two options- HDMI and headphone jack. I followed instructions to get Bluetooth set up (because apparently it doesn't work out of the box) by following the instructions at https://www.raspberrypi.org/magpi/bluet ... erry-pi-3/ When using Blueman however, PulseAudio has a fatal error and when I connect my device it says there's no directory. When I use the regular Pi Bluetooth menu it says to go into the audio menu (which I assume means going to the terminal, putting "sudo raspi-config" and going to the audio menu through there), but it has no option for Bluetooth- only HDMI and headphone port. What I couldn't figure out either is the option to pair is grayed out; I can only connect, which apparently isn't the same thing.

Next I tried to just get it working through HDMI. I made audio go out HDMI, but that didn't work. I found at https://www.raspberrypi.org/documentati ... -config.md to try editing config.txt and uncommenting hdmi_drive=2, which I did. That didn't work either.

Then I tried getting my headphones to work. I plug them in expecting them to work right away, but they don't. I went into the audio menu and selected for audio to come through my headphones- and they didn't work. At this point I was probably working on this for close to three hours and it was getting late at night, and the fact that my mouse decided to stop working as well made me decide to just ask in case this is a special case rather than trying random stuff online.

So basically- am I missing something here, or is my Pi's sound just broken in general?

Thanks for the help. I want to play around with Sonic Pi but that's kind of hard to do when you can't hear what you're doing.

Re: Pi 3- No sound

Posted: Wed Jan 04, 2017 4:15 pm
by youness
Hi,

If you have nothing important in your Raspberry Pi, I recommend that you start again with a fresh Raspbian, then you should have sound trough HDMI and jack out of the box.

For Bluetooth speaker, firstly you don't have to use Blueman or any other graphical setting, I think they don't follow recent PulseAudio changes. So I advice you to read my post here http://youness.net/raspberry-pi/bluetoo ... spberry-pi and try to pair and use your speaker by command line, A2DP should work with no problem is you use follow the steps.

Good luck.