Page 1 of 1

GPIO Server stops after reboot

Posted: Tue Dec 06, 2016 5:40 pm
by HombreSolaire
Hello,
I use pigpio in a project on my raspi.
To get pigpio to work I need to activate "GPIO Server" in the raspi-config (entry AB).
Unfortunately after a reboot this Server needs to activate again via raspi-config. Therefore I see no possibility to run my python script at startup (etc/rc.local)
I would very much apreciate some advice here.
LG
HombreSolaire

Re: GPIO Server stops after reboot

Posted: Tue Dec 06, 2016 6:32 pm
by joan
Use the following command (once) and the daemon should start at boot.

sudo systemctl enable pigpiod

The raspi-config option defines whether the server can be used over the network or just locally.

Re: GPIO Server stops after reboot

Posted: Tue Dec 06, 2016 6:55 pm
by HombreSolaire
Thanks joan for the quick response.
I will try that.
regards
HombreSolaire

Re: GPIO Server stops after reboot

Posted: Wed Dec 07, 2016 2:52 pm
by HombreSolaire
Thanks again,

Code: Select all

sudo systemctl enable pigpiod
worked like a charm
I wonder how can anyone know this stuff? Is it in the man pages of pigpiod? I have no idea?
regards
Hombre

Re: GPIO Server stops after reboot

Posted: Wed Dec 07, 2016 2:56 pm
by joan
HombreSolaire wrote:Thanks again,

Code: Select all

sudo systemctl enable pigpiod
worked like a charm
I wonder how can anyone know this stuff? Is it in the man pages of pigpiod? I have no idea?
regards
Hombre
If falls between two stools, as we say.

It's not part of pigpio, it's part of a Raspberry Pi Org change to Raspbian.