User avatar
Posts: 140
Joined: Fri Mar 20, 2015 2:55 pm

Having an SD Card Reformatting Problem

Fri Nov 25, 2016 3:31 pm

Hi Guys- I have a number of Samsung EVO 32 Gb SD cards in use on several Pi's, so this issue gives me a real concern. :o
Sorry for the excess detail, but I'm not sure what is important info here...

None of them have ever failed or even misbehaved, so I've never tried re-formatting after using them for Raspian OS installations.
I first set them up using the official SDFormatter software on a Tosh laptop. (fyi, I'm very careful about static electricity.)

I just got a 360° LG camera and needed a higher end SD card to use it. I had a backup EVO card for the Adafruit 2.8 PiTFT screen (which I hardly use) so I thought I'd re-use that. That's where my problems started.

I stuck the EVO into the Tosh and started up SDFormatter v4. I was surprised that SDF gave the SD's capacity at 200 & change megabytes and was labelled 'Boot'. I just assumed that would correct itself when the card had reformatted.
I ran it as Overwrite/Format Size Adjustment ON; this took quite a while on a 32Gb card, and when it was done SDF only saw 6 Gigs. In frustration, I then ran the Windows formatting tool which saw the 32 Gigabytes while working but when done only reported 16 Gb with 64 kilobytes used; and the EVO card formatted as FAT32.

Restarting under SDF gives me about the same info- I've 'lost' 16 gigs somewhere along the line.
Will this 'deformatting' happen to any card? Is this card trustworthy for any use at all now?
Or did I make some dumbass mistake? :roll:
Thanks for replies, guys!

User avatar
Forum Moderator
Forum Moderator
Posts: 5458
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Having an SD Card Reformatting Problem

Fri Nov 25, 2016 6:07 pm

I'm guessing that you may have fallen foul of the "inverse" of this pitfall:
ie. the "Windows tools" may "expect" (the first partition of) a 64Gb card to be formatted exFAT. Since I don't have any of such I can't test that hypothesis but, may be, if you have a USB-based card reader you can use in your Pi, Linux tools (such as gparted) might allow you to delete all the partitions and the re-format it with a single parttion (hopefully exFAT). Personally, once I have a device using partition formats that Windows doesn't recognise I will only use Linux tools to re-partition/re-format it. (Historically Windows XP on one occasion "cleaned" a boot partition of a dual-boot system and "broke" the dual-booting process. It turned out that it had changed the UUID of said partition. Once I'd worked out what the new UUID was I was able to repair the bootloader**)
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, and a A+) but Buster on the P4B's. See:

Return to “Troubleshooting”