Page 1 of 1

B+ and a Netgear wireless Dongle

Posted: Sun Nov 20, 2016 12:03 pm
by cabbers
So I solved this problem in the end, but not a satisfactory one and wondering if one of the fine people on here can enlighten me.
B+ with Jessie, I couldn't get a Netgear WNDA3200 2.4+5Ghz dongle to work-when I say work, it came up with lsusb as "no Firmware". If you Google, you'll see this a lot so I made sure the firmware-atheros and usb_modeswitch were installed. Same combo worked on a Pi 2, so I was scratching my head. Eventually plugged a USB 2.0 Belkin 4-port hub into the B+ (as hot-plugging on a B+ for me results in a reboot every time!) and hey presto, the Netgear dongle came up every time when connected to the hub ( rebooting the Pi B+ each time)
I dont know why this is, I take it it must be something electrical that the dongle doesn't get "initialised" on its own?
Not a big deal but would like to know why this would be the case?

cheers

cabs

Re: B+ and a Netgear wireless Dongle

Posted: Sun Nov 20, 2016 12:14 pm
by fruitoftheloom
cabbers wrote:So I solved this problem in the end, but not a satisfactory one and wondering if one of the fine people on here can enlighten me.
B+ with Jessie, I couldn't get a Netgear WNDA3200 2.4+5Ghz dongle to work-when I say work, it came up with lsusb as "no Firmware". If you Google, you'll see this a lot so I made sure the firmware-atheros and usb_modeswitch were installed. Same combo worked on a Pi 2, so I was scratching my head. Eventually plugged a USB 2.0 Belkin 4-port hub into the B+ (as hot-plugging on a B+ for me results in a reboot every time!) and hey presto, the Netgear dongle came up every time when connected to the hub ( rebooting the Pi B+ each time)
I dont know why this is, I take it it must be something electrical that the dongle doesn't get "initialised" on its own?
Not a big deal but would like to know why this would be the case?

cheers

cabs
The Raspberry Pi 1B+ has by default a total of 600mA available on the USB BUS, but it can be set to 1200mA if you have a very good PSU:

In /boot/config.txt.add:

Code: Select all

max_usb_current=1
https://projects.drogon.net/testing-set ... berry-pi-b

https://www.raspberrypi.org/help/faqs/#powerReqs

Re: B+ and a Netgear wireless Dongle

Posted: Sun Nov 20, 2016 2:32 pm
by cabbers
Thanks for the tip but that doesn't make any difference :-( (2.5A charger with 6 " lead)

Will continue trying

cabs