ibwev
Posts: 28
Joined: Fri Jun 17, 2016 2:00 am

RPi3 enable ttyS0

Thu Nov 17, 2016 5:59 am

I have followed this tutorial http://spellfoundry.com/2016/05/29/conf ... ding-pi-3/ to establish serial communication with my RPi3. When I enter

Code: Select all

ls -l /dev
neither ttyS0 nor serial0 is listed. I put

Code: Select all

enable_uart=1
at the last line of /boot/config.txt but after a restart that did not appear to help.

How do I enable ttyS0?

dgordon42
Posts: 710
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: RPi3 enable ttyS0

Thu Nov 17, 2016 10:10 am

Can you post the output of the following three commands:

Code: Select all

uname -a
grep uart /boot/config.txt
cat /boot/cmdline.txt
Thanks,
Dave.

ibwev
Posts: 28
Joined: Fri Jun 17, 2016 2:00 am

Re: RPi3 enable ttyS0

Thu Nov 17, 2016 12:32 pm

Code: Select all

uname -a
Linux Van_RPi3 4.4.26-v7+ #915 SMP Thu Oct 20 17:08:44 BST 2016 armv7l GNU/Linux

Code: Select all

grep uart /boot/config.txt
enable_uart=0
enable_uart=1
I have tried "enable_uart=0" both commented and uncommented

Code: Select all

cat /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
I am assuming that my problem has something to do with

Code: Select all

plymouth.ignore-serial-consoles
. Is it safe to simply remove this from cmdline.txt? If so, do I need to put anything in its place?

dgordon42
Posts: 710
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: RPi3 enable ttyS0

Thu Nov 17, 2016 6:27 pm

The last phrases in '/boot/cmdline.txt', namely "quiet splash plymouth.ignore-serial-consoles" are very recent additions that came with the new 'PIXEL' GUI. They are to do with the splash screen you see when you boot the Pi with an attached monitor. I don't think they affect the operation of the ttyS0 UART. The rest of your '/boot/cmdline.txt' looks good.

enable_uart=0
This is your problem, remove it from '/boot/config.txt'.

There should be one instance of "enable_uart=1" in '/boot/config.txt' for serial port operations.
Reboot your Pi and check for the presence of both '/ttyS0' and '/serial0' in the '/dev' directory.

Hope this helps,
Dave.

ibwev
Posts: 28
Joined: Fri Jun 17, 2016 2:00 am

Re: RPi3 enable ttyS0

Thu Nov 17, 2016 10:53 pm

Thank you so much for the help. The port is working. Apparently I did not restart the last time I commented out "enable_uart=0". This time I removed that line, then restarted, and now it works. You have solved a problem that I have been googling for days.

Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 54 guests