Posts: 4
Joined: Tue Jan 03, 2012 1:12 pm


Mon Sep 03, 2012 1:07 pm

Hi this weekend I hooked up my pi, to my tv (samsung) via my AVR (pioneer).
Saturday it worked fine, including CEC I could navigate and use the basic controls that my samsung remote provides.

On Sunday CEC broke, after openelec hung,
Even after disconnecting the Pi from the AVR, my Tv would not see the ps3 or my receiver, I eventually physically disconnected the Avr from the TV, connected the ps3 directly to the tv, forced a re-scan, then disconnected everything and reconnected the ps3 via the AVR to the TV, forced a scan again which resulted in everything working again.
I was a little concerned that I had done damage to my equipment,
Are there any suggestions, at this stage I'm afraid to connect it again?
(btw, I think the Pi Rocks!!)

Posts: 4
Joined: Tue Jan 03, 2012 1:12 pm

Re: PI Via AVR broke HDMI CEC

Thu Sep 06, 2012 6:12 am

I see revision 2 of the Raspberry PI solves the CEC HDMI issue :D

Posts: 1
Joined: Mon Sep 10, 2012 11:01 am

Re: PI Via AVR broke HDMI CEC

Mon Sep 10, 2012 11:27 am

Same here, samsung plasma tv and denon avr hdmi cec broken, ive tried everything, no luck, reset both devices to factory settings

Posts: 5
Joined: Sun Nov 18, 2012 11:12 am

Re: PI Via AVR broke HDMI CEC

Sun Nov 18, 2012 11:20 am

Dear All,

I hope that I can help. I had also trouble with CEC a lot, also with SAMSUNG TV-s

I have tried several samsung TV from the era.
Anyway there is a bug in the samsung older TV-s eg before 2012 that sometimes in case of unknown thing it forgets the CEC device.

The only way to get it working after a lot of googling I found out that switch off evry devices and take out from the power outlet as well !
Wait till all capacitors discharges (e.g. red lights disappears ) and than reconnect everything and all goes back.

I did not beleive it but it works.

Also I realized with Raspbmc that in case of high CPU idle usage and or overclock could cause to forget the CEC.

I also find out the the image handling from SMB could also cause it.
What I have done so far.
Disable all services. (RSS, UPNP , AIRPLAY, Zeroconf... etc ) and I disabled the multimedia library so I use only foldering, and my Pi is on 0-24 online. Since so far I have no problem with cec.

Return to “Troubleshooting”