NeerajD
Posts: 2
Joined: Fri Oct 14, 2016 11:17 am

No display on monitor

Fri Oct 14, 2016 12:22 pm

I am using Raspberry pi B and i want to use LG monitor using HDMI cable.
The HDMI output is getting displayed on the TV but it is not displayed on the monitor. The screen is blank and nothing is displayed.
Raspbian is installed on the SD card.
I changed the config.txt file and tried uncommenting these following:
hdmi_safe=1
hdmi_force_hotplug=1
config_hdmi_boost=1
But still nothing is displayed on the monitor. What can be the problem? Everything is working on the TV but the same is not displayed on the monitor. The monitor is in good condition. When i connect my laptop to this monitor using HDMI cable, monitor displays the laptop screen as it is. Why the raspberry pi is not working using HDMI on the LG monitor?
Thank you in advance.

wh7qq
Posts: 1475
Joined: Thu Oct 09, 2014 2:50 am

Re: No display on monitor

Fri Oct 14, 2016 7:50 pm

You may get some hints from the sticky in this forum, above:
Setting up HDMI output when video output isn't what you want
The part about being sure that the monitor is turned on before powering the Pi may be germaine. Also, is the LG monitor a native HDMI monitor or are you using a DVI to HDMI adapter? What is its default resolution? Make sure the correct resolution is set in config.txt.

NeerajD
Posts: 2
Joined: Fri Oct 14, 2016 11:17 am

Re: No display on monitor

Sat Oct 15, 2016 10:53 am

Okay. Thank you.
I tried first powering the monitor and then applying power to Raspberry pi, still it is not working.
And i am not using DVI to HDMI adapter, directly HDMI monitor is used. For HDMI, it's showing the resolution as 1366 x 768, 60Hz.
Where can i set the resolution in the config.txt file? I tried uncommenting the following lines:
framebuffer_width=1366
framebuffer_height=768
Is this correct?
What can i do else if this is not working? Can there be any problem with the drivers of the LG monitor?
Thank you.

User avatar
Gavinmc42
Posts: 4679
Joined: Wed Aug 28, 2013 3:31 am

Re: No display on monitor

Sat Oct 15, 2016 11:01 am

Does the monitor have two inputs?
You might have to select the input.
I have old monitors with VGA and DVI input.
PC goes to VGA, Pi goes to a HDMI to DVI cable/adaptor.

Poke some buttons or use onscreen menu?
I'm dancing on Rainbows.
Raspberries are not Apples or Oranges

User avatar
rpdom
Posts: 17588
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: No display on monitor

Sat Oct 15, 2016 12:18 pm

Check the whole config.txt. If you used a NOOBS card it will add duplicate lines at the end of the file to force the monitor settings.

Usually with HDMI or DVI you wouldn't need any of those lines in the file, except possibly the overscan ones.

The framebuffer lines set the internal image size that is used for drawing the screen, not the monitor settings. The GPU will rescale the framebuffer to fit the detected screen size.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 5816
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: No display on monitor

Sat Oct 15, 2016 12:37 pm

If you can remotely login (eg. via SSH with PuTTY or similar) from another computer (or even a second Pi) whilst connected to the non-displaying monitor, information from the tvservice command may be useful. FWIW, I have some "display optimisation" notes here:
http://www.cpmspectrepi.uk/raspberry_pi ... tings.html
HTH,
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B+, P3B, B+, and a A+) but Buster on the P4B's. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

GWillie92
Posts: 1
Joined: Thu Oct 20, 2016 3:56 pm

Re: No display on monitor

Thu Oct 20, 2016 4:08 pm

I am a super raspberri pi 2 NOOB
I have a 7" touchscreen display.
I have done
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install raspberrypi-ui-mods
sudo apt-get install raspberrypi-net-mods

I have also was able to get it to display on my HDMI tv screen perfectly. it just will not display on my screen. I have been literally been thrown a loop and have been searching everywhere for the answers to this problem.

this is my config.txt code
# For more options and information see
# http://www.raspberrypi.org/documentatio ... fig-txt.md
# Some settings may impact device functionality. See link above for details

# rotate screen for picture stand
lcd_rotate=2

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1

#dtparam=i2c_arm=on
#dtparam=i2s=on
dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1

Return to “Troubleshooting”