BartPauwels
Posts: 6
Joined: Thu Oct 15, 2015 7:01 am

WinSCP does not read homedir via Pi3 built-in Wifi

Mon Oct 10, 2016 5:58 pm

When I try to connect to my Raspberry Pi3 with (most recent Rasbian installed via Noobs) with WinSCP, everything works fine over Ethernet. When I try it over the built-in Wifi of the Pi3, my user is authenticated, but when WinSCP is busy "Reading remote directory",
I get the message:
"Host is not communicating for more than 15 seconds. If the problem repeats, try turning off 'Optimimize connection buffer size'".
And later on: "Error listing directory '/home/pi'.".

Turning off 'Optimimize connection buffer size' does not solve the problem.

I know there are problems with the biult-in wifi, I already had to use a workaround to get the time synchronisation working.
WinSCP is version 5.7.5.

Is there a workaround for this ?

wh7qq
Posts: 1475
Joined: Thu Oct 09, 2014 2:50 am

Re: WinSCP does not read homedir via Pi3 built-in Wifi

Tue Oct 11, 2016 2:51 am

The most obvious problem is the short range of the Pi3 wifi. Try getting very close to the router or AP.

Your router setup may not be supporting that access route and I can't help you with your router config but do take a look at it.

There is also a chance that WinSCP may not play nice with the linux filesystem on the RPi...harder to sort out if you are locked into Windows GUI usage but if you are up to it, try using a live linux iso such as https://www.linuxmint.com/edition.php?id=220.

BartPauwels
Posts: 6
Joined: Thu Oct 15, 2015 7:01 am

Re: WinSCP does not read homedir via Pi3 built-in Wifi

Tue Oct 11, 2016 7:06 am

Hi,

I tried with the Pi3 and the router next to each other, it didn' help.

I do not expect a problem with the router or its setup, because it worked well with a Raspberry Pi2 with an Edimax Wifi dongle, with the same router, and the same Windows PC. And it works fine on the Pi3 over ethernet, and that ethernet connection also passes the same router (used as hub in that case).

Keep in mind that there are more problems reprted woth the Pi3 wifi. Reading other forum topics, it seems to be a software problem on the Pi, probably the driver for Pi's wifi hardware.

Look at the workaround for this one:
viewtopic.php?t=141454&f=28

The workaround is described in the post by by SR-71 of Sat Mar 26, 2016 9:50 pm. It works, so Pi3 can finally synchronise date and time via Wifi.

I suppose we will need a workaround like this.
If I understood that workaround, maybe I could make one for this cas myself.

A definitive solution for the wifi problems with the Pi3 would of course be better the individual workarouns for each problem.

wh7qq, General helpdesk-style remarks like the ones you gave wil not help us any futher in this case. It would be great if someone could try to reproduce the problem and look for a workaroudn or a solution.

Unfortunately, I do not have a PC with Linux to test with instead.

Bart

Return to “Troubleshooting”