Page 1 of 1

GUI Login doesn't work on new PIXEL

Posted: Sat Oct 01, 2016 4:25 am
by mitchh22
I flashed a new microsd with the latest version of Raspbian. First boot works great and it goes straight to the desktop.
On reboot it ends up at the login screen with the pi user selected in the dropdown.. If I put the correct password and try to login, the screen goes black for a second then just ends up right on the login screen again.

I SSH'd into the pi and tried setting the raspi-config boot options to both GUI options with no success.
Choosing to boot to terminal and autologin works fine, but not for the desktop.

Am I the only one experiencing this?

Re: GUI Login doesn't work on new PIXEL

Posted: Sat Oct 01, 2016 2:08 pm
by CaptSunset
Hi Mitch; I've only booted Pixel a few times so far (since yesterday ;) ).
No problems at all arriving at the Desktop with the default setup. (This being the stock Pi user.)

I overwrote and then reformatted an older 16G card using the recommended SDFormatter software before copying on the extracted set of files. I noticed there are 4 separate data files apparently for the 2B, 3B, 1, & 0. It is possible your problem could be there.
I'd recommend reformatting your card and re-copying the Pixel software onto it.
Also, there are already a couple apt-get upgrades available.

If that doesn't help, you should post clearer info- did you use NOOBS or Raspian? Did you use network install?

Re: GUI Login doesn't work on new PIXEL

Posted: Wed Oct 05, 2016 9:14 pm
by Peppironi89
Hey guys,

first post here, status noob on raspberry..
same problem.
as i remember i didn't change passwords and everything i try gives the 'error' text, but with the password 'raspberry' it goes black for a few seconds and the login screen pops up again..
very wierd..

Yesterday it rebooted all fine multiple times and after installing VCNserver and rebooted this stinky stink started to occur..

hope for some help here..

Thnx,
Cheers!

Re: GUI Login doesn't work on new PIXEL

Posted: Thu Oct 06, 2016 4:17 am
by tdatu
Same issue here... The only change that I did was to disable the overscan in /boot/config.txt
After I restarted the system, and I entered the default credentials into the login screen, the screen goes black and takes me back to the login screen again. I think the X server crashes. Can anybody help or idea?

Re: GUI Login doesn't work on new PIXEL

Posted: Thu Oct 06, 2016 12:04 pm
by UlrichH
I have the exact same problem. I just received a new Rasp3 this morning, made a new SD card with the most recent Raspbian image, and everything is working just fine except I can't log in through the GUI.

Re: GUI Login doesn't work on new PIXEL

Posted: Thu Oct 06, 2016 1:01 pm
by simplastic
Exact same issue here too.

I installed the new Raspian with PIXEL yesterday via a new noobs with network, opted for dual boot with LibreELEC and added recommended data partition. I've done not tinkered with anything other than the overscan settings (see above!), run apt-get update and apt-get upgrade. I rebooted maybe three times too.

Today I tried to log in and it's prompting me for a password. Typing "raspberry" is not working. It appears to accept it, goes to a black screen for 2 seconds and then kicks me back to the login prompt. Any other password gives me an incorrect password error message straight away without the black screen. I also checked the input (UK keyboard) via the 'other' login and it is definitely typing "raspberry".

I've logged in from my PC with SSH using "pi" and "raspberry" and it logs straight in, so the password is correct.

I could just re-flash and maybe I will need to. However, this looks like some kind of system bug that needs addressing. This was way to easy to break!

Re: GUI Login doesn't work on new PIXEL

Posted: Tue Oct 25, 2016 7:39 pm
by Huckle
When at the buggy login screen, press Ctrl+Alt+F1 to enter the command line and type:

Code: Select all

sudo chown pi:pi .Xauthority
reboot
It solved the issue in my case. It seems related to VNC and there before PIXEL:
viewtopic.php?t=28521

Hope it helps, cheers!