gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Trouble connecting pi 3 to router via WiFi

Fri Sep 09, 2016 3:32 am

I'm a new user (just received my first pi today) and would appreciate help with getting my wifi connected. I did search before posting, and the most useful thing I found seemed to be here:

https://www.raspberrypi.org/documentati ... ess-cli.md

Having failed while using the icon at upper right in the gui I tried the technique outlined on that page. When editing wpa_supplicant.conf, I discovered that there was already an entry for my router with the first two lines precisely matching what was shown for ssid and psk. I assume that came about during my attempts to connect via the gui.

There was also a 3rd line, which read as follows: key_mgmt=WPA-PSK

I figured that might be my problem, since my router is running WPA2 Version 1. I tried making that change, and also tried it with simply WPA2, but if anything those attempts made things worse - after rebooting, I couldn't see any connections at all. I then tried using just the ssid and psk lines as shown on the web link, but no joy. Checking back, I see that the system has once again added the third line reading key_mgmt=WPA-PSK. (I'd be fine with that if it would connect, but it wont.)

On the router side, I've double checked that I added the correct mac address for the pi to my list of authorized connections. My problem doesn't lie there; I've added a couple of dozen devices previously and never had a problem connecting with them.

So basically I'm stuck. Having done some reading before my pi arrived, I expected it might be difficult to connect my bluetooth keyboard, but I got through that OK. It's the wifi, which I figured would be easy, that has me stumped. I'd very much appreciate hearing from someone who has suggestions about what to try next.

klricks
Posts: 6593
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
Contact: Website

Re: Trouble connecting pi 3 to router via WiFi

Fri Sep 09, 2016 4:30 am

I would try it without MAC filtering. It's useless anyway: http://www.howtogeek.com/204458/why-you ... fi-router/
Have you set the country code?

This is my wpa_supplicant file:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
        ssid="YourSSID"
        psk="your pass phrase"
        key_mgmt=WPA-PSK
}
Unless specified otherwise my response is based on the latest and fully updated Raspbian Buster w/ Desktop OS.

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Fri Sep 09, 2016 4:56 am

Thanks for your response. That link was depressing; I knew having the access list wasn't foolproof but that article makes it sound awfully weak. That said, It takes me next to no time to maintain and I'd much prefer to keep it as is if I can find another solution. Seems weird that the pi can't connect if it works for everything else I've tried (not just laptops but phones, tablets, my tv, the wii, etc).

I did already have the country code set to US; basically my wpa_supplicant file is identical to yours. I'm assuming you aren't using MAC filtering on your router and that I could connect by disabling it on mine, but I think I'll wait and hope somebody has an alternative solution.

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Sun Sep 11, 2016 6:49 am

Well, I seem to be digging myself a deeper hole.
I found this link, which looked really promising:
http://www.raspyfi.com/wi-fi-on-raspber ... ple-guide/

I then installed wicd and wicd-curses, and followed the instructions on that page. Not only did I fail to connect the wifi, I lost the ethernet connection as well. I've tried multiple reboots, also powering down the modem and router, but can't connect via either ethernet or wifi. The router is still happily supplying my laptop, and everything looks normal when using routerlogin.net.

On the pi I've checked the wpa_supplicants config, and nothing seems to have changed there. They say when you're deep in a hole stop digging, but I'm determined to get this sorted. I'd be truly grateful if somebody could put me on the right track.

User avatar
nl3prc
Posts: 160
Joined: Sun Jul 24, 2016 12:39 pm
Location: Den Helder the netherlands

Re: Trouble connecting pi 3 to router via WiFi

Sun Sep 11, 2016 11:26 am

do you get any routers that are visible by entering
sudo iwlist wlan0 scan

and mine looks like below

Code: Select all

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
    ssid="SSID"
    psk="passkey"
}

User avatar
DougieLawson
Posts: 36178
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Trouble connecting pi 3 to router via WiFi

Sun Sep 11, 2016 12:37 pm

What security does your router/AP use? If it's WEP then that's almost as bad as MAC address filtering for being completely insecure. Change everything to WPA/WPA2 and your RPi will "just work".
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Sun Sep 11, 2016 4:54 pm

nl3prc wrote:do you get any routers that are visible by entering
sudo iwlist wlan0 scan

and mine looks like below

Code: Select all

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
    ssid="SSID"
    psk="passkey"
}
I did have them prior to my attempt to connect using wicd-curses. Now I get this:

Code: Select all

wlan0   Interface doesn't support scanning :  Network is down

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Sun Sep 11, 2016 4:57 pm

DougieLawson wrote:What security does your router/AP use? If it's WEP then that's almost as bad as MAC address filtering for being completely insecure. Change everything to WPA/WPA2 and your RPi will "just work".
My router is using WPA2-PSK [AES]

Ethernet worked until yesterday; haven't succeeded in connecting via wifi even once.

User avatar
nl3prc
Posts: 160
Joined: Sun Jul 24, 2016 12:39 pm
Location: Den Helder the netherlands

Re: Trouble connecting pi 3 to router via WiFi

Sun Sep 11, 2016 5:05 pm

What if you remove wicd-curses
sudo apt-get remove wicd-curses
Is then your wlan0 back

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Sun Sep 11, 2016 5:36 pm

nl3prc wrote:What if you remove wicd-curses
sudo apt-get remove wicd-curses
Is then your wlan0 back
Yes! Removed curses (which in my case at least was well named) and rebooted. I'm back online via ethernet - thank you so much!
BTW, I did not remove wicd - figured I'd change things one step at a time and it was only the wicd-curses that was causing the problem.

Now if I could get the wifi connection as well it would be awesome...

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Sun Sep 11, 2016 10:15 pm

I thought I should update my current situation in case anyone else happens to look in.

My internet connection works fine via the ethernet cable. After booting I can see multiple wireless connection points, including my own, but all attempts at connecting with the preloaded wifi utilities fail.

I have wicd installed. I installed wicd-curses too, but had to remove it because it was causing problems (I assume those were self inflicted wounds because I used it improperly).

Using the icon for wicd on the toolbar I can bring up a screen that appears to give me correct information about both my ethernet connection and the available wifi sources. Mine is shown as being at 100% and having WPA2 on Channel 2. My router setup is WPA2-PSK [AES], with a list of devices for which connection is permitted.

I set the properties in wicd for my connection to "Use Encryption" and set the encryption type to "WPA 1/2 (Passphrase)". I enter my passphrase (and have re-entered it umpteen times just in case). I then try to connect and wicd breezes through several steps, then hangs longer than I'd expect at "Validating authentication...". Apparently it times out after 20-30 seconds, then reports "Connection failed - bad passphrase". I'm dead certain the passphrase is correct, but I'm not winning that argument.

After trying (and failing) to connect with wicd, clicking the wireless connection icon on the task bar at upper right reports "No wireless interfaces found", so I have to reboot before trying that approach again. Not that it matters; if I could connect that way I wouldn't have installed wicd in the first place.

Any and all suggestions appreciated.

User avatar
nl3prc
Posts: 160
Joined: Sun Jul 24, 2016 12:39 pm
Location: Den Helder the netherlands

Re: Trouble connecting pi 3 to router via WiFi

Mon Sep 12, 2016 9:18 am

after it fails to connect and before reboot what are the line's below tels you
sudo ifconfig
sudo iwlist wlan0 scan
i my case i'm using a raspberry 1 B+ i have a usb dongle in one of the usb port's for WiFi
and i think you are using the internal WiFi adaptor
i read somewhere that there must also be a wpa_supplicant.conf in your /boot/ directori maybe thats the trick here

And check if your interface is there in /etc/network/interfaces

mine looks like below

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Mon Sep 12, 2016 8:45 pm

nl3prc wrote:after it fails to connect and before reboot what are the line's below tels you
sudo ifconfig
sudo iwlist wlan0 scan
i my case i'm using a raspberry 1 B+ i have a usb dongle in one of the usb port's for WiFi
and i think you are using the internal WiFi adaptor
i read somewhere that there must also be a wpa_supplicant.conf in your /boot/ directori maybe thats the trick here

And check if your interface is there in /etc/network/interfaces
Mine is a new raspberry 3, and one of the things that may be different is that interface file. I don't have a interfaces folder under /etc/network - I do have /etc/network/interfaces.d but it is empty.

I'd tried changing wpa_supplicant.conf with no success (see my first two posts in this thread).

I'm pasting in what I see back using the two sudo commands you suggested:

Code: Select all

[email protected]:~ $ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:b0:3e:5b  
          inet6 addr: fe80::ae61:9d25:65d0:3121/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:192 errors:0 dropped:0 overruns:0 frame:0
          TX packets:192 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:15552 (15.1 KiB)  TX bytes:15552 (15.1 KiB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:e5:6b:0e  
          inet6 addr: fe80::4fb4:47c:b51b:ac1b/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:254 errors:0 dropped:246 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:93645 (91.4 KiB)  TX bytes:1751 (1.7 KiB)

Code: Select all

wlan0     Scan completed :
          Cell 01 - Address: 00:22:3F:A8:E0:24
                    Channel:2
                    Frequency:2.417 GHz (Channel 2)
                    Quality=70/70  Signal level=-28 dBm  
                    Encryption key:on
                    ESSID:"my_router_name"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000000000000000
                    Extra: Last beacon: 70ms ago
                    IE: Unknown: 000B474146576972656C657373
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030102
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: DD180050F2020101020003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C334E101BFF00000000000000000000000000000000000000000000
                    IE: Unknown: 2D1A4E101BFF00000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C34020D0A00000000000000000000000000000000000000
                    IE: Unknown: 3D16020D0A00000000000000000000000000000000000000
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD0A00037F04010000000000
                    IE: Unknown: DD820050F204104A000110104400010210570001001041000100103B00010310470010565AA94967C14C0EAA8FF349E6F593111021000D4E6574676561722C20496E632E10230007574E523130303010240007574E523130303010420004353637381054000800060050F204000110110007574E5231303030100800020084103C000103
 
I've taken out the lines for cells 2-10.

Thanks again for looking at this...

User avatar
nl3prc
Posts: 160
Joined: Sun Jul 24, 2016 12:39 pm
Location: Den Helder the netherlands

Re: Trouble connecting pi 3 to router via WiFi

Mon Sep 12, 2016 9:16 pm

mm you could try and add de file interfaces you can always delete it if it does nothing

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
But are there any file's in the interfaces.d directory mine is empty

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Mon Sep 12, 2016 10:12 pm

nl3prc wrote:mm you could try and add de file interfaces you can always delete it if it does nothing

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
But are there any file's in the interfaces.d directory mine is empty
My interfaces.d file is also empty. I take it you want me to create a new file with the text as shown and put it in my interfaces.d, but what should I name the file?

Also, I think I have an issue during boot that may be relevant. It disappears too quickly for me to read, but I managed to take a picture (see attachment).

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Mon Sep 12, 2016 10:25 pm

2nd attempt to post the image; didn't realize there was a 64kb size limit so I had to reduce it considerably. I hope it's still legible.
boot issue.jpg
Rpi3 boot issue
boot issue.jpg (12.24 KiB) Viewed 3063 times

User avatar
DougieLawson
Posts: 36178
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Trouble connecting pi 3 to router via WiFi

Mon Sep 12, 2016 10:53 pm

It's illegible.

Post the full size image on http://imgur.com, post the imgur [img]...[/img] link on here.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Mon Sep 12, 2016 11:33 pm

The pic lost a lot when I uploaded it to Imgur as well. I've typed it out:

Code: Select all

[   1.083230] brcmfmac: brcmf_sdio_drivestrengthinit: No SDIO Drive strength init done for chip 43430 rev 1 pmurev 24
/init: line 27: can't create /sys/class/leds/led0/trigger: nonexistent directory
[   1.322577] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = w10: Dec 15 2015 18:10:45 version 7.45.41.23 (r606571) FWID 01-cc4eda9c
[   1.338f84] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code

User avatar
DougieLawson
Posts: 36178
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Trouble connecting pi 3 to router via WiFi

Mon Sep 12, 2016 11:38 pm

What have you got in /boot/config.txt?
What kernel/firmware version are you running?

With imgur there's no size limits, don't shrink your images if you're posting them on there for a link on here.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Tue Sep 13, 2016 12:04 am

DougieLawson wrote:What have you got in /boot/config.txt?
Most of what's in there is commented. There are three active lines:

Code: Select all

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1

# added 9-10-16 in attempt to run with 24 bit color
framebuffer_depth=24
That last one was something I added to get 24 bit color; seems to work fine. The wifi connection issues were the same before I put that in; I could take it out again but I don't think it would matter.


DougieLawson wrote:What kernel/firmware version are you running?
The current Raspian version. I bought a canakit that had Noobs, used that to install raspian, then ran sudo update and sudo upgrade.
DougieLawson wrote:With imgur there's no size limits, don't shrink your images if you're posting them on there for a link on here.
I understand that; maybe I uploaded the wrong one. Rather than mess with it further I decided to just type the three lines and be done with it.
Last edited by gaffer on Tue Sep 13, 2016 5:56 am, edited 2 times in total.

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Tue Sep 13, 2016 12:21 am

Googling tells me that brcmfmac has to do with the onboard broadcom wifi, and I'm guessing that really is the root of all my troubles. I wish I knew more about the subject...

Trying to anticipate what I might be asked next, I have this:

Code: Select all

[email protected]:~ $ dmesg | grep brcm
[    4.724158] usbcore: registered new interface driver brcmfmac
[    4.925268] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: May 27 2016 00:13:38 version 7.45.41.26 (r640327) FWID 01-df77e4a7
[    4.945853] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[    5.116648] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[    6.025157] brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
[    6.025182] brcmfmac: brcmf_add_if: ignore IF event
[    6.030191] brcmfmac: power management disabled
[    9.187208] brcmfmac: brcmf_cfg80211_escan: Connecting: status (3)
[    9.187221] brcmfmac: brcmf_cfg80211_scan: scan error (-11)
[   30.470889] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code

User avatar
DougieLawson
Posts: 36178
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Trouble connecting pi 3 to router via WiFi

Tue Sep 13, 2016 8:00 am

None of those messages are any problem at all.

What version of the kernel are you running? What does a uname -a command emit?

What's in /etc/network/interfaces?
What's in /etc/dhcpcd.conf
What's in /etc/wpa_supplicant/wpa_supplicant.conf (you may want to redact your password if you post the contents here)

What do you get from the following commands
ifconfig -a
ps auxf | grep wpa_supp


Are there any exciting messages in /var/log/messages or /var/log/syslog?
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
nl3prc
Posts: 160
Joined: Sun Jul 24, 2016 12:39 pm
Location: Den Helder the netherlands

Re: Trouble connecting pi 3 to router via WiFi

Tue Sep 13, 2016 8:20 am

gaffer wrote:
nl3prc wrote:mm you could try and add de file interfaces you can always delete it if it does nothing

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
But are there any file's in the interfaces.d directory mine is empty
My interfaces.d file is also empty. I take it you want me to create a new file with the text as shown and put it in my interfaces.d, but what should I name the file?

Also, I think I have an issue during boot that may be relevant. It disappears too quickly for me to read, but I managed to take a picture (see attachment).
in my case the file is in /etc/network/ and is named interfaces
some one also told me that a firmware update could solve your problem but it is tricky to do you might get other problems when doing so

gaffer
Posts: 32
Joined: Fri Sep 09, 2016 2:14 am

Re: Trouble connecting pi 3 to router via WiFi

Tue Sep 13, 2016 3:30 pm

DougieLawson wrote:None of those messages are any problem at all.

What version of the kernel are you running? What does a uname -a command emit?

Code: Select all

Linux raspberrypi 4.4.13-v7+ #894 SMP Mon Jun 13 13:13:27 BST 2016 armv7l GNU/Linux
DougieLawson wrote:What's in /etc/network/interfaces?

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
(I've removed the bit I had added that changed color depth)
DougieLawson wrote:What's in /etc/dhcpcd.conf

Code: Select all

# A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.
hostname

# Use the hardware address of the interface for the Client ID.
clientid
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC436$
#duid

# Persist interface configuration when dhcpcd exits.
persistent

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU.
# Some interface drivers reset when changing the MTU so disabled by default.
#option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private

# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
nohook lookup-hostname
DougieLawson wrote:What's in /etc/wpa_supplicant/wpa_supplicant.conf (you may want to redact your password if you post the contents here)

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
        ssid="my_router_name"
        psk="my_password"
        key_mgmt=WPA-PSK
}
I should probably mention again here that I was trying to fix the problem by changing wpa_supplicant.conf the other day. Here's the version that I had the highest hopes for:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
	ssid="my_router_name"
	psk="my_password"
        proto=RSN
	key_mgmt=WPA2-PSK
        pairwise=CCMP
        auth_alg=OPEN
}
It didn't seem to help; failed to connect as usual.
DougieLawson wrote:What do you get from the following commands
ifconfig -a

Code: Select all

eth0      Link encap:Ethernet  HWaddr b8:27:eb:b0:3e:5b  
          inet addr:10.0.0.2  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::ae61:9d25:65d0:3121/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1148 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1287 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:895588 (874.5 KiB)  TX bytes:193756 (189.2 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3720 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3720 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:301776 (294.7 KiB)  TX bytes:301776 (294.7 KiB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:e5:6b:0e  
          inet6 addr: fe80::4fb4:47c:b51b:ac1b/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:32341 errors:0 dropped:32338 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:13608633 (12.9 MiB)  TX bytes:1115 (1.0 KiB)
DougieLawson wrote:ps auxf | grep wpa_supp[/color]

Code: Select all

root       424  0.0  0.3   7252  3720 ?        Ss   Sep12   0:15 /sbin/wpa_supplicant -s -B -P /run/wpa_supplicant.wlan0.pid -i wlan0 -D nl80211,wext -c /etc/wpa_supplicant/wpa_supplicant.conf
pi       23674  0.0  0.1   4280  1816 pts/0    S+   07:48   0:00 grep --color=auto wpa_supp
DougieLawson wrote:Are there any exciting messages in /var/log/messages or /var/log/syslog?
Large files and I have to run. I'll report back on those later...
Last edited by gaffer on Fri Sep 16, 2016 7:14 am, edited 1 time in total.

User avatar
nl3prc
Posts: 160
Joined: Sun Jul 24, 2016 12:39 pm
Location: Den Helder the netherlands

Re: Trouble connecting pi 3 to router via WiFi

Tue Sep 13, 2016 7:00 pm

after rpi-update you now get kernel 4.4.19+

Return to “Troubleshooting”