xandman99
Posts: 3
Joined: Mon Aug 29, 2016 5:27 pm

Retropie HDMI = No sound

Mon Aug 29, 2016 5:34 pm

Ive read and read on topics relating to this before I posted up (and im sorry if this is something dumb)

Im running a Pi zero and ive got RetroPie working with games playable but no sound. I have looked in tot he config file and added a few lines from other posts that claimed to fix the issue and yet nothing. Below is what my config file looks like....any help guys?
# For more options and information see
# http://www.raspberrypi.org/documentatio ... fig-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes


# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256
overscan_scale=1
#hdmi_force_hotplug=1
#hdmi_force_edid_audio=1
#hdmi_group=1
#hdmi_mode=16

RAZERZ
Posts: 57
Joined: Mon Jun 13, 2016 4:56 pm

Re: Retropie HDMI = No sound

Mon Aug 29, 2016 6:33 pm

Hello and welcome to the Troubleshooting section of the pi forums.

Try to issue "sudo raspi-config", then using your arrow keys, navigate to Advanced options (9) and in there navigate to audio and select your source.

Hope that helped ;)
Raspberry pi 3 set up as desktop with raspbian.
I guess you can say I am not newbie with linux but I am not a master at it either.
I will always try to help you as much as I can because I know how hard it is to run into problems :D

xandman99
Posts: 3
Joined: Mon Aug 29, 2016 5:27 pm

Re: Retropie HDMI = No sound

Mon Aug 29, 2016 6:35 pm

Ive already told it to output through HDMI but no luck.

Return to “Troubleshooting”