User avatar
rpikurti
Posts: 37
Joined: Sun Jul 17, 2016 9:59 am

module i2c missing

Wed Aug 17, 2016 9:15 am

Hello to all,
I'm new here and I use a RPI for several applications.
Most of them are sensors which are connected to the i2c-port.
Now I have one problem using a LCD-display.
I do not know what drivers I need for this.
The supplier provides a image (=Linux rpizero 4.4.11 #2 Tue May 24 22:50:33 CST 2016 armv6l GNU/Linux) which works very good for the LCD display :) . But...
I can not use the i2c port.
If I run
raspi-config
I get the following message:
There was an error running option A6 I2
and
modprobe: FATAL: Module i2c-dev not found.
I think I need to add the i2c modules to the image.
I have 2 questions:
  • what i2c module do I need?
    where can i get this?
    how to add this modules ti the image?
You see I'm not an expert in making kernel.
Please can anybody give me a hint how to solve this problem?
Thanks a lot in advance!
Kurt

User avatar
DougieLawson
Posts: 36322
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: module i2c missing

Wed Aug 17, 2016 10:05 am

Run sudo rpi-update to get the 4.4.17 kernel and replace your missing modules.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
rpikurti
Posts: 37
Joined: Sun Jul 17, 2016 9:59 am

Re: module i2c missing

Thu Aug 18, 2016 5:07 pm

Thanks DougieLawson,
I did execute sudo rpi-update and after the reboot there was a message on the LCD screen (watchdog watchdog0 did not stop!) :( .
Then the LCD display dit not work anymore. :oops:
I checked the item and it's a 3.5 LCD display for SPI interface which has been made by kedei and the image I got from here:
Does somebody have any idea what I can do to ger the LCD and i2c working?
Thanks!

Kurt

User avatar
DougieLawson
Posts: 36322
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: module i2c missing

Fri Aug 19, 2016 1:07 am

You'll need to reinstall your screen drivers.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

User avatar
rpikurti
Posts: 37
Joined: Sun Jul 17, 2016 9:59 am

Re: module i2c missing

Fri Aug 19, 2016 10:05 am

Hi,
thanks for your answer but I have no idea where I get this drivers. If I install the drivers provited by kedei.net Then the i2c drivers have gone.
Neither I can activate them by running raspi-config.

User avatar
DougieLawson
Posts: 36322
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: module i2c missing

Sat Aug 20, 2016 6:33 am

You'll need to ask the nice folks at http://kedei.net to put them back. If they've built the kernel without I2C support then they'll have to fix it for you.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

doublehp
Posts: 77
Joined: Wed May 02, 2012 1:11 am

Re: module i2c missing

Tue Jan 24, 2017 6:40 pm

I also had this issue.

I had downloaded rpi_35_v6_0_2_jessie_kernel_4_4_11.rar in september 2016, and had this issue.

I redownlaoded today rpi_35_v6_1_2_3_jessie_kernel_4_4_19.rar from http://kedei.net/raspberry/raspberry.html and it seems to contain the driver (according to /lib/modules directory; not running it yet).

doublehp
Posts: 77
Joined: Wed May 02, 2012 1:11 am

Re: module i2c missing

Thu May 17, 2018 1:43 pm

On a rPi v1, I also using pigpio to emulate I2C on the misc IO pins

http://abyz.me.uk/rpi/pigpio/

https://en.wikipedia.org/wiki/Raspberry_Pi
P5(6), GPIO 28 to 31.

Return to “Troubleshooting”