Page 1 of 1

pi 2 usb power dies

Posted: Wed Jul 27, 2016 8:59 pm
by nikki_81
I have been using a pi 2 since its launch to run octoprint but the usb power has started to die 30 + minutes into a print. i have tested the 5v supply and that is fine are there any known issues that will be making this problem ?

thanks Nikki

Re: pi 2 usb power dies

Posted: Wed Jul 27, 2016 11:23 pm
by drgeoff
How have you tested the PSU?

Re: pi 2 usb power dies

Posted: Thu Jul 28, 2016 6:34 am
by nikki_81
yes i have tested the psu and its ok.

Re: pi 2 usb power dies

Posted: Thu Jul 28, 2016 7:23 am
by drgeoff
nikki_81 wrote:yes i have tested the psu and its ok.
For the last time, how have you tested the PSU?

Re: pi 2 usb power dies

Posted: Thu Jul 28, 2016 9:51 am
by nikki_81
the psu is a 400w (33 amps) 5v led psu that also powers the printer. the pi dies but the printer remains on. i have also tried powering the pi from a separate psu (3 amp) with the same usb power problem after 30 + mins. I have also tested all my usb devices wifi adapter,webcam and arduino and they are all fine running on a old model b pi.

thanks Nikki

Re: pi 2 usb power dies

Posted: Thu Jul 28, 2016 10:22 am
by RaTTuS
so you mean the RPI dies after 30mins or so
what is shown in the logs ?

Re: pi 2 usb power dies

Posted: Thu Jul 28, 2016 10:25 am
by davidcoton
nikki_81 wrote:the psu is a 400w (33 amps) 5v led psu that also powers the printer.
Something wrong there. 400W at 5V is 80A. Does the 400W include other rails?

Does the red power LED stay on?
What does "vcgencmd get_throttled" say?
What does "vcgencmd measure_temp" say?

Can you measure the 5V rail on the Pi itself? preferably just before it fails :lol:

Re: pi 2 usb power dies

Posted: Thu Jul 28, 2016 1:08 pm
by nikki_81
sorry yes i forgot it has a 5-12v buck built in to the psu :oops:

I have managed to lend a second pi 2 from a friend and everything is working perfectly again,looks like i have got a faulty pi :roll:

thanks nikki