helicta
Posts: 8
Joined: Sat Aug 23, 2014 11:09 am

Rainbow Freeze

Mon Jul 25, 2016 12:14 pm

Hi everybody !

I've a problem, when I start my Raspberry Pi B+, the green light flash two times (for 2/3 secondes) and then a big rainbow square appears on the screen.

I've tried to change power supply, micro USB cable shorter, set boot_delay=1 in config.txt and nothing works.

I don't know what to do anymore, does someone have the same problem ?

Thanks a lot.

drgeoff
Posts: 11518
Joined: Wed Jan 25, 2012 6:39 pm

Re: Rainbow Freeze

Mon Jul 25, 2016 12:25 pm

What OS is on the card and how did it get on there?

Has this ever worked previously?
Quis custodiet ipsos custodes?

User avatar
RaTTuS
Posts: 10741
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: Rainbow Freeze

Mon Jul 25, 2016 12:59 pm

How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

RAZERZ
Posts: 57
Joined: Mon Jun 13, 2016 4:56 pm

Re: Rainbow Freeze

Mon Jul 25, 2016 1:23 pm

When the big rainbow square appears, does it appear as a small square in the top right corner of the screen or just huge in the middle?
Raspberry pi 3 set up as desktop with raspbian.
I guess you can say I am not newbie with linux but I am not a master at it either.
I will always try to help you as much as I can because I know how hard it is to run into problems :D

helicta
Posts: 8
Joined: Sat Aug 23, 2014 11:09 am

Re: Rainbow Freeze

Mon Jul 25, 2016 1:51 pm

I've tried several softwares as libreelec, OpenElec, and Osmc. Now it's runing on OpenElec.

There is only a huge rainbow square, no little square.

To be precise, the raspberry used to work a year and a half ago on OpenElec (with the problem of little square top right of the screen). Then I did not use it for 1y1/2 and then I've formated the new OpenElec with Kodi build and these problems happened...

RAZERZ
Posts: 57
Joined: Mon Jun 13, 2016 4:56 pm

Re: Rainbow Freeze

Mon Jul 25, 2016 7:19 pm

If it only happens once, at boot, that is normal. As long as it does not happen at random times, that is unusual. I have seen multiple youtube videos were that happens, infact this (if you forward to 5:30) will show it.
Raspberry pi 3 set up as desktop with raspbian.
I guess you can say I am not newbie with linux but I am not a master at it either.
I will always try to help you as much as I can because I know how hard it is to run into problems :D

Return to “Troubleshooting”